networking/wifi.nix
networking/lte.nix
networking/nftables.nix
- ./wireguard.nix
../../nixos/profiles/dnscrypt-proxy2.nix
- ../../nixos/profiles/wireguard/wg-intra.nix
../../nixos/profiles/networking/ssh.nix
];
install.substituteOnDestination = false;
'';
networking.networkmanager.enable = true;
- services.avahi.enable = true;
- services.avahi.openFirewall = true;
- services.avahi.publish.enable = true;
+ services.avahi = {
+ enable = true;
+ openFirewall = true;
+ nssmdns4 = true;
+ publish = {
+ enable = true;
+ addresses = true;
+ domain = true;
+ hinfo = true;
+ userServices = true;
+ workstation = true;
+ };
+ };
# WARNING: settings.listen_addresses are not merged...
# hence there all defined here.
services.dnscrypt-proxy2.settings.listen_addresses = [