{
+ imports = [
+ ./ssh.nix
+ ];
# On a remote headless server: always reboot on a kernel panic,
# to not have to physically go power cycle the server.
# Which may happen for instance if the wrong ZFS password is used
boot.kernelParams = [ "panic=10" ];
programs.gnupg.agent.pinentryFlavor = "curses";
- programs.mosh.enable = mkDefault true;
# Always try to start all the units (default.target)
# because systemd's emergency shell does not try to start sshd.
# https://wiki.archlinux.org/index.php/systemd#Disable_emergency_mode_on_remote_host
systemd.enableEmergencyMode = false;
-
- services.openssh.enable = true;
}