vim: tweak ALE key bindings
[julm/julm-nix.git] / nixos / profiles / networking / remote.nix
index 04306692da4b1f2ddca5d8f8f1a63f1d897f2336..e4dbba06e6b0c33269217c44c05abc3118e27a53 100644 (file)
@@ -1,4 +1,7 @@
 {
+  imports = [
+    ./ssh.nix
+  ];
   # On a remote headless server: always reboot on a kernel panic,
   # to not have to physically go power cycle the server.
   # Which may happen for instance if the wrong ZFS password is used
@@ -8,12 +11,9 @@
   boot.kernelParams = [ "panic=10" ];
 
   programs.gnupg.agent.pinentryFlavor = "curses";
-  programs.mosh.enable = mkDefault true;
 
   # Always try to start all the units (default.target)
   # because systemd's emergency shell does not try to start sshd.
   # https://wiki.archlinux.org/index.php/systemd#Disable_emergency_mode_on_remote_host
   systemd.enableEmergencyMode = false;
-
-  services.openssh.enable = true;
 }