1 { pkgs, lib, config, ... }:
2 let inherit (lib) types;
7 ./defaults/predictable-interface-names.nix
11 autoOptimiseStore = true;
14 # Use gc.automatic to keep disk space under control.
18 options = "--delete-older-than 30d";
26 packageOverrides = pkgs: {
27 postfix = pkgs.postfix.override {
33 #overlays = import ../overlays.nix;
36 documentation.nixos = {
37 enable = false; # NOTE: useless on a server, and CPU intensive.
40 # Clean /tmp automatically on boot.
41 boot.cleanTmpDir = true;
44 timeZone = "Europe/Paris";
48 consoleFont = "Lat2-Terminus16";
50 defaultLocale = "fr_FR.UTF-8";
67 systemPackages = with pkgs; [
86 etc."inputrc".text = lib.readFile defaults/readline/inputrc;
91 interactiveShellInit = ''
92 bind '"\e[A":history-search-backward'
93 bind '"\e[B":history-search-forward'
95 # Ignore duplicate commands, ignore commands starting with a space
96 export HISTCONTROL=erasedups:ignorespace
99 # Append to the history instead of overwriting (good for multiple connections)
106 ls = "ls --color=tty";
107 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
110 s-u="systemctl --user";
112 nixos-clean="sudo nix-collect-garbage -d";
113 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
114 nixos-rollback="sudo nixos-rebuild switch --rollback";
115 nixos-update="sudo nix-channel --update";
116 nixos-upgrade="sudo nixos-rebuild switch";
117 nixos-upstream="sudo nix-channel --list";