sourcephile
/
git
/
sourcephile-nix.git
/ blob
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
history
|
raw
|
HEAD
git: ignore previous nix formatting
[sourcephile-nix.git]
/
hosts
/
mermet
/
nginx
/
sourcephile.fr
/
covid19.nix
1
{ domain, ... }:
2
{ config, ... }:
3
let
4
inherit (config.services) nginx;
5
srv = "covid19";
6
in
7
{
8
services.nginx = {
9
virtualHosts."${srv}.${domain}" = {
10
forceSSL = true;
11
useACMEHost = domain;
12
root = "/home/julm/www/${srv}";
13
extraConfig = ''
14
access_log off;
15
error_log /dev/null crit;
16
'';
17
locations."/".extraConfig = ''
18
index index.html;
19
'';
20
};
21
};
22
}