1 { pkgs, lib, config, ... }:
2 # NOTE: list explicitely the modules loaded by defaults.nix,
3 # its clearer, safer and more flexible if not quicker.
6 modules/services/networking/domains.nix
7 #modules/services/networking/knot.nix
8 modules/services/databases/openldap.nix
9 modules/services/mail/public-inbox.nix
10 #modules/services/mail/mlmmj.nix
13 "services/mail/public-inbox.nix"
14 "services/mail/mlmmj.nix"
19 # NOTE: this modules.nix file is put in the imports of the configuration.nix,
20 # but using the lib.findFiles defined in the nixpkgs.overlays leads to an infinite recursion,
21 # hence it is redefined here:
22 let findFiles = pattern:
25 let dir = readDir curr; in
26 let files = lib.filterAttrs (name: type:
28 match pattern name != null) dir; in
29 let dirs = lib.filterAttrs (name: type: type == "directory") dir; in
30 map (name: "${curr}/${name}") (attrNames files) ++
31 lib.concatMap (name: go "${curr}/${name}") (attrNames dirs)
36 imports = findFiles ".*\\.nix" ./modules;