1 { config, inputs, ... }:
7 (inputs.julm-nix + "/nixos/profiles/wireguard/${wgIface}.nix")
10 systemd.services."wireguard-${wgIface}".serviceConfig.LoadCredentialEncrypted = [
11 "privateKey:${./. + "/${wgIface}/privateKey.cred"}"
13 networking.wireguard.${wgIface}.peers = {
14 aubergine.enable = true;
15 losurdo.enable = true;
19 networking.nftables.ruleset = ''
22 tcp dport ssh counter accept comment "SSH"
23 udp dport 60000-60100 counter accept comment "Mosh"
26 tcp dport ssh counter accept comment "SSH"
27 udp dport 60000-60100 counter accept comment "Mosh"