2 nixpkgs_channel = builtins.getEnv "nixpkgs_channel";
3 originNixpkgs = import (.config/nixpkgs-channel + ("/" + nixpkgs_channel + ".nix"));
4 originPkgs = import originNixpkgs {
5 config = {}; # Make the config pure, ignoring user's config.
10 { meta.description = "nsd : use types.lines where appropriate";
11 url = "https://github.com/NixOS/nixpkgs/pull/78968.diff";
12 sha256 = "11bqq1g1ax6i7xghihyhklmqpsq3njalardp6nvzphkjgxrypb47";
14 { meta.description = "shorewall: init at 5.2.3.3";
15 url = "https://github.com/NixOS/nixpkgs/pull/46131.diff";
16 sha256 = "0mfzlcr23ni5spnwksmmls50sw10alqbr5j6hjrwp9i30z0419yx";
19 { meta.description = "Dovecot plugin for Full Text Search (FTS) with Xapian";
20 url = "https://github.com/NixOS/nixpkgs/pull/78780.diff";
21 sha256 = "053md69ryybj27cp0xdfrza48zyzpblk6wvb2m2dbs9hm0gmcwc4";
23 /* Disabled because it triggers the local build of too many reverse-dependencies
24 { meta.description = "openldap: enable sha2 and pbkdf2 modules";
25 url = "https://github.com/NixOS/nixpkgs/pull/79286.diff";
26 sha256 = "0y255x74qksqy7fm4bdwlknhm3s55vgfgbv4dd7580p4lcavya0m";
30 { meta.description = "Replace simp-le with lego and support DNS-01 challenge";
31 url = "https://github.com/NixOS/nixpkgs/pull/77578.diff";
32 sha256 = "15zs2146zh54jg1gywrcwyqxpx7izc35vlakk3cvrlqwwsvlr2rf";
35 { meta.description = "dstat: fix pluginpath";
36 url = "https://github.com/NixOS/nixpkgs/pull/80151.diff";
37 sha256 = "0jjw2gvp7b7v2n2m2d6yj0gw711j6p9lyjf5ywp2y9ql6905qf4b";
39 { meta.description = "shorewall: fix warnings due to types.loaOf being deprecated";
40 url = "https://github.com/NixOS/nixpkgs/pull/80154.diff";
41 sha256 = "0b216m1rib3jl6s3r5cbkd5h1bfhppikg4cz9ayr1fspsflr3bci";
43 { meta.description = "shorewall: fix RestartTriggers";
44 url = "https://github.com/NixOS/nixpkgs/pull/81774.diff";
45 sha256 = "14drpym2mq9gq505psjzqq23gv0wkbwrrvh438h5jirzcym3467a";
48 localNixpkgsPatches = [
51 nixpkgs = originPkgs.stdenv.mkDerivation {
52 name = "nixpkgs-patched";
54 phases = [ "unpackPhase" "patchPhase" ];
55 patches = map originPkgs.fetchpatch nixpkgsPatches ++ localNixpkgsPatches;
57 patch=$(printf '%s\n' ${builtins.concatStringsSep " " (map (p: p.sha256) nixpkgsPatches)} |
58 sort | sha256sum | cut -c -7)
60 echo "+patch-$patch" >$out/.version-suffix
63 pkgs = import nixpkgs {
64 config = {}; # Make the config pure, ignoring user's config.
65 overlays = import ./overlays.nix;
70 nixos = pkgs.nixos {};
71 # Configuration of shell/modules/
72 configuration = {config, ...}: {
77 auto-optimise-store = true
85 gnupgHome = toString ../sec/gnupg;
86 keys = import shell/openpgp.nix;
88 trusted-key 0xB2450D97085B7B8C
93 opensslHome = toString ../sec/openssl;
94 certificates = import shell/x509.nix;
97 # WARNING: nixops uses its own ssh, not this one.
100 Ciphers aes256-gcm@openssh.com,aes128-gcm@openssh.com,aes256-ctr
104 ControlPath ${builtins.toString ../sec/ssh}/ssh-%h-%p-%r.socket
106 #SSAPIAuthentication no
108 StrictHostKeyChecking yes
109 UserKnownHostsFile ${builtins.toString ../sec/ssh/known_hosts}
117 # Using modules enables to separate specific configurations
118 # from reusable code in shell/modules.nix and shell/modules/
119 # which may find its way in another git repository one day.
121 (import shell/modules.nix {
123 modules = [ configuration ];
127 name = "sourcephile-nix";
129 #preferLocalBuild = true;
130 #allowSubstitutes = false;
131 buildInputs = modules.nix-shell.buildInputs ++ [
132 nixos.nixos-generate-config
166 #pkgs.rxvt_unicode.terminfo
185 #enableParallelBuilding = true;
187 echo >&2 "nix: running shellHook"
190 PATH=$NIX_SHELL_PATH:$PATH
191 export NIX_PATH="nixpkgs=${toString pkgs.path}:nixpkgs-overlays="$PWD"/overlays"
192 export nixpkgs_channel=${nixpkgs_channel}
194 # Cleanup "../sec/tmp/"
195 # This is done when entering the nix-shell
196 # because direnv already hooks trap EXIT.
197 (cd "$PWD" && find ../sec/tmp -type f -exec shred -fu {} +)
199 ${modules.nix-shell.shellHook}
202 export PASSWORD_STORE_DIR="$PWD"/../sec/pass
205 export GPG_TTY=$(tty)
206 gpg-connect-agent updatestartuptty /bye >/dev/null
209 #export NIXOPS_DEPLOYMENT="staging"
210 export NIXOPS_STATE="$PWD"/../sec/nixops/state.nixops
211 NIXOPS_OPTS+=" --show-trace"
215 #export DISNIXOS_USE_NIXOPS=1
216 #export DISNIX_CLIENT_INTERFACE=disnix-nixops-client
217 #export DISNIX_PROFILE=default
218 #export DISNIX_TARGET_PROPERTY=hostname
219 #export DYSNOMIA_STATEDIR="$PWD"/../sec/dysnomia