sourcephile
/
git
/
sourcephile-nix.git
/ blob
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
history
|
raw
|
HEAD
nftables: remove redundant check-broadcast
[sourcephile-nix.git]
/
hosts
/
mermet
/
nginx
/
sourcephile.fr
/
covid19.nix
1
{ domain, ... }:
2
{ pkgs, lib, config, ... }:
3
let
4
inherit (config) networking;
5
inherit (config.services) nginx;
6
srv = "covid19";
7
in
8
{
9
services.nginx = {
10
virtualHosts."${srv}.${domain}" = {
11
forceSSL = true;
12
useACMEHost = domain;
13
root = "/home/julm/www/${srv}";
14
extraConfig = ''
15
access_log off;
16
error_log /dev/null crit;
17
'';
18
locations."/".extraConfig = ''
19
index index.html;
20
'';
21
};
22
};
23
}