sourcephile
/
git
/
sourcephile-nix.git
/ blob
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
history
|
raw
|
HEAD
nix: cleanup defaults
[sourcephile-nix.git]
/
hosts
/
carotte
/
networking.nix
1
{ pkgs, lib, config, hostName, ... }:
2
{
3
imports = [
4
networking/wireguard/intranet.nix
5
];
6
networking = {
7
hostName = hostName;
8
domain = "sourcephile.fr";
9
firewall.enable = true;
10
firewall.allowedTCPPorts = [ 22 ];
11
#wireless.enable = true;
12
useDHCP = true;
13
#networkmanager.enable = true;
14
};
15
services.openssh = {
16
forwardX11 = true;
17
};
18
programs.ssh = {
19
extraConfig = ''
20
Compression = yes
21
'';
22
};
23
}