2 nixpkgs = import .config/nixpkgs-channel/nixos-19.09-small.nix;
3 pkgs = import nixpkgs {
4 config = {}; # Make the config pure, ignoring user's config.
5 overlays = import ./overlays.nix;
9 # Configuration of shell/modules/
10 configuration = {config, ...}: {
15 auto-optimise-store = true
23 gnupgHome = toString ../sec/gnupg;
24 keys = import shell/openpgp.nix;
28 opensslHome = toString ../sec/openssl;
29 certificates = import shell/x509.nix;
32 # WARNING: nixops uses its own ssh, not this one.
35 Ciphers aes256-gcm@openssh.com,aes128-gcm@openssh.com,aes256-ctr
39 ControlPath ${builtins.toString ../sec/ssh}/ssh-%h-%p-%r.socket
41 #SSAPIAuthentication no
43 StrictHostKeyChecking yes
44 UserKnownHostsFile ${builtins.toString ../sec/ssh/known_hosts}
52 # Using modules enables to separate specific configurations
53 # from reusable code in shell/modules.nix and shell/modules/
54 # which may find its way in another git repository one day.
56 (import shell/modules.nix {
58 modules = [ configuration ];
61 pkgs.stdenv.mkDerivation {
62 name = "sourcephile-nix";
64 #preferLocalBuild = true;
65 #allowSubstitutes = false;
66 buildInputs = modules.nix-shell.buildInputs ++ [
68 nixos.nixos-generate-config
100 #pkgs.rxvt_unicode.terminfo
119 #enableParallelBuilding = true;
121 echo >&2 "nix: running shellHook"
123 # Cleanup "../sec/tmp/"
124 # This is done when exiting the nix-shell
125 # (or when… entering the directory with direnv
126 # which spawns a nix-shell just to get the env).
127 trap "cd '$PWD' && find ../sec/tmp -type f -exec shred -fu {} +" EXIT
129 ${modules.nix-shell.shellHook}
132 export NIX_PATH="nixpkgs=${nixpkgs}"
133 NIX_PATH+=":nixpkgs-overlays="$PWD"/overlays"
137 PATH_NIX="$(dirname "$(PATH="${builtins.getEnv "PATH"}"; which nix)")"
138 PATH_NIXOS=/run/wrappers/bin
139 export PATH="$PATH_NIXOS:$PATH:$PATH_NIX:/usr/sbin:/usr/bin:/bin"
141 # NOTE: sudo needs to be own by root with the setuid bit,
142 # but this won't be the case for the sudo provided by Nix outside NixOS,
143 # hence the addition of $PATH_FHS in shellHook
144 # to provide the host system's sudo.
145 # WARNING: beware that sudo may reset the environment,
146 # and especially PATH, to some system's default.
149 export LANG=fr_FR.UTF-8
150 export LC_CTYPE=fr_FR.UTF-8
153 export PASSWORD_STORE_DIR="$PWD"/../sec/pass
156 export GPG_TTY=$(tty)
157 gpg-connect-agent updatestartuptty /bye >/dev/null
161 test ! -f "$gitdir" || while IFS=" :" read -r hdr gitdir; do [ "$hdr" != gitdir ] || break; done <"$gitdir"
163 "$PWD"/.lib/git/hooks/prepare-commit-msg--longuest-common-prefix \
164 "$gitdir"/hooks/prepare-commit-msg
167 #export NIXOPS_DEPLOYMENT="staging"
168 export NIXOPS_STATE="$PWD"/../sec/nixops/state.nixops
169 NIXOPS_OPTS+=" --show-trace"
173 #export DISNIXOS_USE_NIXOPS=1
174 #export DISNIX_CLIENT_INTERFACE=disnix-nixops-client
175 #export DISNIX_PROFILE=default
176 #export DISNIX_TARGET_PROPERTY=hostname
177 #export DYSNOMIA_STATEDIR="$PWD"/../sec/dysnomia