{ pkgs, lib, config, ... }:
let
  inherit (builtins) elem attrValues;
  inherit (config.users) users groups;
in
{
imports = [
  acme/autogeree.net.nix
  acme/sourcephile.fr.nix
];
security.acme = {
  acceptTerms = true;
};
environment.systemPackages = [
  pkgs.lego
];
/*
users.users.acme = {
  home = "/var/lib/acme";
  group = groups."acme".name;
  # Set a static UID to install the credentialFile
  # with acme:root perms before the system switch
  uid = 14;
  isSystemUser = true;
};
assertions = [
  { assertion = ! elem users.acme.uid (attrValues config.ids.uids);
    message = ''
      Unix user ID ${toString users.acme.uid} is already taken in config.ids.uids: change for a free UID.
    '';
  }
];
*/
users.groups = {
  acme = {};
};

}