{ pkgs, lib, config, ... }:
let
  inherit (config) networking;
in
{
# This value determines the NixOS release with which your system is to be
# compatible, in order to avoid breaking some software such as database servers.
# You should change this only after NixOS release notes say you should.
system.stateVersion = "19.09"; # Did you read the comment?

# Avoid the use of systemd-run --user --scope tmux
# and let mosh work smoothly.
services.logind.killUserProcesses = false;

nix.gc.dates = "daily";
nix.gc.options = "--delete-older-than 7d";

services.unbound.enable = true;
documentation.nixos = {
  enable = false; # NOTE: useless on a server, and CPU intensive.
};

environment.systemPackages = with pkgs; [
  cryptsetup
  direnv
  file
  fio
  gdb
  git
  gptfdisk
  #hey
  home-manager
  lm_sensors
  rsync
  #smartctl-tbw
  socat
  sanoid
  #iptables-nftables-compat
  gnupg
  miniupnpc
  audit
  python
];
}