{ pkgs, lib, config, ... }:
let inherit (lib) types;
    inherit (config) networking;
    inherit (config.services) postfix;
in
{
options.services.postfix.aliases = lib.mkOption {
  type    = with types; attrsOf (listOf str);
  default = {};
  example = { "root@${networking.domain}" = [
                "user1@${networking.domain}"
                "user2@${networking.domain}"
              ];
              "@example.coop" = ["user1@${networking.domain}"];
            };
};
}