{ lib, ... }:
let inherit (lib) types;
in
{
  options = {
    nix-shell.buildInputs = lib.mkOption {
      type = types.listOf types.package;
      default = [ ];
      description = ''
        To be prepended to the shell.nix's buildInputs.
      '';
    };
    nix-shell.shellHook = lib.mkOption {
      type = types.lines;
      default = "";
      description = ''
        To be prepended to the shell.nix's shellHook.
      '';
    };
  };
}