{ domain, ... }:
{ pkgs, lib, config, ... }:
let
  inherit (config) networking;
  inherit (config.services) nginx;
  srv = "covid19";
in
{
services.nginx = {
  virtualHosts."${srv}.${domain}" = {
    forceSSL = true;
    useACMEHost = domain;
    root = "/home/julm/www/${srv}";
    extraConfig = ''
      access_log off;
      error_log  /dev/null crit;
    '';
    locations."/".extraConfig = ''
      index index.html;
    '';
  };
};
}