{ inputs, pkgs, lib, config, ... }:
{
nix.extraOptions = ''
  experimental-features = nix-command flakes
'';
#nix.registry.self.flake = inputs.self;
# Pin the rev to the revision of the public Nixpkgs that the system was built from.
# This is the version which will be locked by flakes using flake:nixpkgs
nix.registry.nixpkgs = {
  from = { id = "nixpkgs"; type = "indirect"; };
  to = {
    owner = "NixOS";
    repo = "nixpkgs";
    rev = inputs.nixpkgs.rev;
    type = "github";
  };
};
/*
# WARNING: this is a hack to avoid copying Nixpkgs
# a second time into the Nix store.
# It makes only sense when Nixpkgs is already in the Nix store,
# and is registered.
environment.etc."nixpkgs".source = pkgs.path;
environment.etc."nixpkgs-overlays".source =
  pkgs.writeTextDir "overlays.nix" ''
    import ${inputs.self + "/nixpkgs/overlays.nix"} ++
    import ${inputs.julm-nix + "/nixpkgs/overlays.nix"}
  '';
nix.nixPath = [
  "nixpkgs=/etc/nixpkgs:nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
];
*/
environment.systemPackages = [
  pkgs.valgrind
];
}