{ pkgs, lib, config, inputs, hostName, ... }:
let inherit (config) networking; in
{
# This value determines the NixOS release with which your system is to be
# compatible, in order to avoid breaking some software such as database servers.
# You should change this only after NixOS release notes say you should.
system.stateVersion = "19.09"; # Did you read the comment?

services.unbound.enable = true;

nix.gc.dates = "daily";
nix.gc.options = "--delete-older-than 2d";
nix.binaryCaches = [ "http://nix-extracache.losurdo.wg" ];
nix.binaryCachePublicKeys = [ (builtins.readFile (inputs.secrets + "/hosts/losurdo/nix/binary-cache-key/1.pub")) ];

environment.systemPackages = with pkgs; [
  cryptsetup
  direnv
  file
  fio
  gdb
  git
  gptfdisk
  #hey
  home-manager
  lm_sensors
  rsync
  smartctl-tbw
  socat
  #thttpd
  #iptables-nftables-compat
];
}