nix: add module security.pass
[sourcephile-nix.git] / nixos / modules / services / networking / domains.nix
index 664935dfccafe2256f65d94693cd27a4844baa7e..a784c2da514b23641df1183c83601e11cd74a511 100644 (file)
@@ -7,31 +7,5 @@ options.networking = {
     description = "Base network name.";
     example     = "example";
   };
-  domainAliases = lib.mkOption {
-    type        = types.listOf types.str;
-    description = "Domain aliases.";
-    example     = [ "example.org" "example.net" ];
-  };
-  zones = lib.mkOption {
-    type = types.attrsOf (types.submodule ({name, options, config, ...}: {
-      options = {
-        iface = lib.mkOption {
-          type        = types.str;
-          description = "Interface name.";
-          example     = "eth0";
-        };
-        ipv4 = lib.mkOption {
-          type        = types.str;
-          description = "Static IPv4 address of the machine.";
-          example     = "1.2.3.4";
-        };
-        ipv6 = lib.mkOption {
-          type        = types.str;
-          description = "Static IPv6 address of the machine.";
-          example     = "fe80::1";
-        };
-      };
-    }));
-  };
 };
 }