self: super:
+with builtins;
let lib = super.lib; in
{
lib = (super.lib or {}) // {
+ loadFile = name: toFile (baseNameOf (toString name)) (readFile name);
findFiles = pattern:
- with builtins;
let go = curr:
let dir = readDir curr; in
let files = lib.filterAttrs (name: type:
map (name: "${curr}/${name}") (attrNames files) ++
lib.concatMap (name: go "${curr}/${name}") (attrNames dirs)
;
- in root: go (toPath root);
+ in go;
};
}