mermet: fail2ban: add intranet on the ignoreIP
[sourcephile-nix.git] / nixos / profiles / hardware / dl10j.nix
index 0fadf48dda477085683599709fbd3340245c916c..38ce9386fa8265b0b64d9732cf12f21aae67b850 100644 (file)
@@ -1,10 +1,18 @@
-{ pkgs, lib, config, ... }:
+{ pkgs, lib, config, host, ... }:
 {
 hardware.cpu.intel.updateMicrocode = true;
+hardware.opengl = {
+  extraPackages = [
+    pkgs.intel-media-driver # LIBVA_DRIVER_NAME=iHD
+    pkgs.vaapiIntel         # LIBVA_DRIVER_NAME=i965 (older but works better for Firefox/Chromium)
+    pkgs.vaapiVdpau
+    pkgs.libvdpau-va-gl
+  ];
+};
 nix = {
   # Too CPU hungry for the DL10J, for too little Mio saved
   autoOptimiseStore = false;
-  maxJobs = 2;
+  maxJobs = host.CPUs;
 };
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
@@ -55,7 +63,7 @@ boot.initrd = {
     "igb" # Ethernet
     # Make the AES modules available at initrd,
     # to speedup the deciphering of the root.
-    "aes_x86_64"
+    #"aes_x86_64"
     "aesni_intel"
     "cryptd"
   ];