-{ pkgs, lib, config, ... }:
+{ pkgs, lib, config, host, ... }:
{
hardware.cpu.intel.updateMicrocode = true;
+hardware.opengl = {
+ extraPackages = [
+ pkgs.intel-media-driver # LIBVA_DRIVER_NAME=iHD
+ pkgs.vaapiIntel # LIBVA_DRIVER_NAME=i965 (older but works better for Firefox/Chromium)
+ pkgs.vaapiVdpau
+ pkgs.libvdpau-va-gl
+ ];
+};
nix = {
# Too CPU hungry for the DL10J, for too little Mio saved
autoOptimiseStore = false;
- maxJobs = 2;
+ maxJobs = host.CPUs;
};
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
"igb" # Ethernet
# Make the AES modules available at initrd,
# to speedup the deciphering of the root.
- "aes_x86_64"
+ #"aes_x86_64"
"aesni_intel"
"cryptd"
];