{ pkgs, lib, config, ... }:
{
hardware.cpu.intel.updateMicrocode = true;
-nix = {
- # Too CPU hungry for the DL10J, for too little Mio saved
- autoOptimiseStore = false;
- maxJobs = 2;
+hardware.opengl = {
+ extraPackages = [
+ pkgs.intel-media-driver # LIBVA_DRIVER_NAME=iHD
+ pkgs.vaapiIntel # LIBVA_DRIVER_NAME=i965 (older but works better for Firefox/Chromium)
+ pkgs.vaapiVdpau
+ pkgs.libvdpau-va-gl
+ ];
};
+
+# Too CPU hungry for this hardware, for too little Mio saved
+nix.settings.auto-optimise-store = false;
+
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
# https://insanity.industries/post/sata-power-consumption/
'';
boot.loader = {
+ efi = {
+ canTouchEfiVariables = false;
+ efiSysMountPoint = "/boot/efi";
+ };
grub = {
enable = true;
version = 2;
];
*/
};
- efi = {
- canTouchEfiVariables = false;
- efiSysMountPoint = "/boot/efi";
- };
};
boot.initrd = {
"igb" # Ethernet
# Make the AES modules available at initrd,
# to speedup the deciphering of the root.
- "aes_x86_64"
+ #"aes_x86_64"
"aesni_intel"
"cryptd"
];
"igb" # Ethernet
"nvme" # NVME M.2 disk
"rtsx_usb_sdmmc" # SD card
+ "ums_realtek" # SD card
];
};
-boot.kernelModules = [ ];
+boot.kernelModules = [
+ "rtsx_usb_sdmmc" # SD card
+ "ums_realtek" # SD card
+];
boot.extraModulePackages = [ ];
boot.kernelParams = [
"gfxpayload=text"