mermet: iodine: setup
[sourcephile-nix.git] / nixos / profiles / hardware / dl10j.nix
index 0fadf48dda477085683599709fbd3340245c916c..73dd09c72df4136e95803ecdc314534acee8c6d6 100644 (file)
@@ -1,11 +1,18 @@
 { pkgs, lib, config, ... }:
 {
 hardware.cpu.intel.updateMicrocode = true;
-nix = {
-  # Too CPU hungry for the DL10J, for too little Mio saved
-  autoOptimiseStore = false;
-  maxJobs = 2;
+hardware.opengl = {
+  extraPackages = [
+    pkgs.intel-media-driver # LIBVA_DRIVER_NAME=iHD
+    pkgs.vaapiIntel         # LIBVA_DRIVER_NAME=i965 (older but works better for Firefox/Chromium)
+    pkgs.vaapiVdpau
+    pkgs.libvdpau-va-gl
+  ];
 };
+
+# Too CPU hungry for this hardware, for too little Mio saved
+nix.settings.auto-optimise-store = false;
+
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
 # https://insanity.industries/post/sata-power-consumption/
@@ -14,6 +21,10 @@ services.udev.extraRules = ''
 '';
 
 boot.loader = {
+  efi = {
+    canTouchEfiVariables = false;
+    efiSysMountPoint = "/boot/efi";
+  };
   grub = {
     enable = true;
     version = 2;
@@ -33,10 +44,6 @@ boot.loader = {
     ];
     */
   };
-  efi = {
-    canTouchEfiVariables = false;
-    efiSysMountPoint = "/boot/efi";
-  };
 };
 
 boot.initrd = {
@@ -55,7 +62,7 @@ boot.initrd = {
     "igb" # Ethernet
     # Make the AES modules available at initrd,
     # to speedup the deciphering of the root.
-    "aes_x86_64"
+    #"aes_x86_64"
     "aesni_intel"
     "cryptd"
   ];
@@ -63,9 +70,13 @@ boot.initrd = {
     "igb" # Ethernet
     "nvme" # NVME M.2 disk
     "rtsx_usb_sdmmc" # SD card
+    "ums_realtek" # SD card
   ];
 };
-boot.kernelModules = [ ];
+boot.kernelModules = [
+  "rtsx_usb_sdmmc" # SD card
+  "ums_realtek" # SD card
+];
 boot.extraModulePackages = [ ];
 boot.kernelParams = [
   "gfxpayload=text"