-{ pkgs, lib, config, hostName, ... }:
+{ inputs, ... }:
{
-imports = [
- ../../nixos/profiles/hardware/cubieboard2.nix
- ../../nixos/profiles/systems/zramSwap.nix
- ../../nixos/profiles/systems/crossCompilation.nix
-];
+ imports = [
+ ../../nixos/profiles/hardware/cubieboard2.nix
+ ../../nixos/profiles/systems/crossCompilation.nix
+ (inputs.julm-nix + "/nixos/profiles/zramSwap.nix")
+ ];
+ # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
+ # You should try to make this id unique among your hosts.
+ # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
+ networking.hostId = "f155106a";
}