mermet: gitweb: fix charset for html
[sourcephile-nix.git] / hosts / carotte / hardware.nix
index 54acb06d5e156eb60dc44870babe254a23150c54..9b7d216f37bc4dc260e33f8f0ebafa5eacb630e7 100644 (file)
@@ -1,8 +1,12 @@
-{ pkgs, lib, config, hostName, ... }:
+{ inputs, ... }:
 {
-imports = [
-  ../../nixos/profiles/hardware/cubieboard2.nix
-  ../../nixos/profiles/systems/zramSwap.nix
-  ../../nixos/profiles/systems/crossCompilation.nix
-];
+  imports = [
+    ../../nixos/profiles/hardware/cubieboard2.nix
+    ../../nixos/profiles/systems/crossCompilation.nix
+    (inputs.julm-nix + "/nixos/profiles/zramSwap.nix")
+  ];
+  # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
+  # You should try to make this id unique among your hosts.
+  # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
+  networking.hostId = "f155106a";
 }