nix: update input julm-nix
[sourcephile-nix.git] / shell.nix
index e3823f2f2a92f5cc605d6a54032ea97d77882ae3..477117f8924f1610b7f5e6e952e09fecfe4d71af 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -1,78 +1,35 @@
+{ inputs, pkgs, shellHook ? "", ... }:
 let
-  nixpkgs_channel = builtins.getEnv "nixpkgs_channel";
-  # Bootstraping Nixpkgs to get tools to patch it.
-  originNixpkgs = import (.config/nixpkgs-channel + ("/${nixpkgs_channel}.nix"));
-  originPkgs = import originNixpkgs {
-    config = {}; # Make the config pure, ignoring user's config.
-    overlays = [];
-  };
-  remoteNixpkgsPatches = [
-    { meta.description = "dstat: fix pluginpath";
-      url = "https://github.com/NixOS/nixpkgs/pull/80151.diff";
-      sha256 = "0jjw2gvp7b7v2n2m2d6yj0gw711j6p9lyjf5ywp2y9ql6905qf4b";
-    }
-    { meta.description = "syncoid: fix PATH to let it use sudo";
-      url = "https://github.com/NixOS/nixpkgs/pull/83901.diff";
-      sha256 = "0q2dicmvl3h3hb9xdd870n5hf6lac489p000c7f1r6k70sh2id4l";
-    }
-    { meta.description = "sanoid: fix sanoid.conf generation";
-      url = "https://github.com/NixOS/nixpkgs/pull/83904.diff";
-      sha256 = "0lj4krmmbz82zpmbacw0qj2ywsx895bq4d1psjn753ymh7jjqj8k";
-    }
-    { meta.description = "nixos/public-inbox: init";
-      url = "https://github.com/NixOS/nixpkgs/pull/77450.diff";
-      sha256 = "13ikg7chpbf6rrg5sngbdb95q3awhdgl4g8vci42xmqyf208hzzd";
-    }
-  ];
-  localNixpkgsPatches = [
-  ];
-  # Build nixpkgs with some patches.
-  nixpkgs = originPkgs.applyPatches {
-    name = "nixpkgs-patched";
-    src = originNixpkgs;
-    patches = map originPkgs.fetchpatch remoteNixpkgsPatches ++ localNixpkgsPatches;
-    postPatch = ''
-      patch=$(printf '%s\n' ${builtins.concatStringsSep " "
-         (map (p: p.sha256) remoteNixpkgsPatches ++ localNixpkgsPatches)} |
-        sort | sha256sum | cut -c -7)
-      echo "+patch-$patch" >.version-suffix
-    '';
-  };
-  # Final pkgs with custom overlays.
-  pkgs = import nixpkgs {
-    config = {}; # Make the config pure, ignoring user's config.
-    overlays = import nixpkgs/overlays.nix;
-  };
-
-  lib = pkgs.lib;
-  nixos = pkgs.nixos {};
   # Configuration of shell/modules/
   # to expand shellHook and buildInputs of this shell.nix
-  configuration = {config, ...}: {
+  shellConfig = { ... }: {
     imports = [
       shell/gnupg.nix
     ];
-    nix = {
-      nixConf = ''
-        auto-optimise-store = true
-      '';
-    };
-    nix-plugins = {
-      enable = true;
-    };
     gnupg = {
       enable = true;
-      gnupgHome = toString ../sec/gnupg;
+      gnupgHome = "../sec/gnupg";
       gpgExtraConf = ''
         # julm@sourcephile.fr
         trusted-key 0xB2450D97085B7B8C
+        default-key 0x4FE467034C11017B429BAC53A58CD81C3863926F
+      '';
+      gpgAgentExtraConf = ''
+        #pretend-request-origin remote
+        #extra-socket ${toString ./.}/S.gpg-agent.extra
+        #log-file ${toString ./.}/gpg-agent.log
+        #no-grab
+        #debug-level expert
+        #allow-loopback-pinentry
       '';
     };
-    openssl = {
+    /*
+      openssl = {
       enable = true;
-      opensslHome = toString ../sec/openssl;
+      opensslHome = "../sec/openssl";
       certificates = import shell/x509.nix;
-    };
+      };
+    */
     openssh = {
       enable = true;
       sshConf = ''
@@ -80,12 +37,12 @@ let
         Compression no
         #CompressionLevel 4
         ControlMaster auto
-        ControlPath ${toString ../sec/ssh}/ssh-%h-%p-%r.socket
+        ControlPath .ssh-%h-%p-%r.socket
         HashKnownHosts no
         #SSAPIAuthentication no
         SendEnv LANG LC_*
         StrictHostKeyChecking yes
-        UserKnownHostsFile ${toString ../sec/ssh/known_hosts}
+        #UserKnownHostsFile ''${inputs.secrets + "/ssh/known_hosts"}
       '';
     };
     virtualbox = {
@@ -96,33 +53,22 @@ let
   # Using modules enables to separate specific configurations
   # from reusable code in shell/modules.nix and shell/modules/
   # which may find its way in another git repository one day.
-  modules =
-    (import shell/modules.nix {
-      inherit pkgs lib;
-      modules = [ configuration ];
-    }).config;
-
-  pwd = toString (./. + "");
-  sourcephile-shred-tmp = pkgs.writeShellScriptBin "sourcephile-shred-tmp" ''
-    # This is done when entering the nix-shell
-    # because direnv already hooks trap EXIT.
-    cd "${pwd}"
-    test ! -e sec/tmp || {
-    find sec/tmp -type f -exec shred -fu {} +
-    rm -rf sec/tmp
-    }
-  '';
+  shell = (pkgs.lib.evalModules {
+    modules = [
+      shellConfig
+      { config._module.args = { inherit inputs pkgs; }; }
+    ] ++ map import (pkgs.lib.findFiles ".*\\.nix" shell/modules);
+  }).config;
 in
 pkgs.mkShell {
   name = "sourcephile-nix";
   src = null;
   #preferLocalBuild = true;
   #allowSubstitutes = false;
-  buildInputs = modules.nix-shell.buildInputs ++ [
-    sourcephile-shred-tmp
-    nixos.nixos-generate-config
-    nixos.nixos-install
-    nixos.nixos-enter
+  buildInputs = shell.nix-shell.buildInputs ++ [
+    (pkgs.nixos [ ]).nixos-generate-config
+    (pkgs.nixos [ ]).nixos-install
+    (pkgs.nixos [ ]).nixos-enter
     #pkgs.binutils
     pkgs.coreutils
     pkgs.cryptsetup
@@ -166,39 +112,40 @@ pkgs.mkShell {
     #pkgs.vim
     #pkgs.virtualbox
     pkgs.which
-    pkgs.xdg_utils
-    pkgs.zfs
+    pkgs.xdg-utils
     pkgs.fio
     pkgs.strace
     pkgs.utillinux
     #pkgs.zfstools
+    pkgs.linuxPackages.perf
+    #pkgs.go2nix
+    pkgs.wireguard-tools
+    pkgs.stun
+    pkgs.mkpasswd
+    #pkgs.ubootTools
+    #pkgs.hydra-unstable
   ];
   #enableParallelBuilding = true;
-  shellHook = ''
-    echo >&2 "nix: running shellHook"
 
-    # password-store
-    export PASSWORD_STORE_DIR="$PWD"/../sec/pass
-
-    # Nix
-    PATH=$NIX_SHELL_PATH:$PATH
-    export NIX_PATH="${lib.concatStringsSep ":" [
-      "servers=$PWD/servers.nix"
-      #"pass=$PASSWORD_STORE_DIR"
-      "nixpkgs=${toString pkgs.path}"
-      "nixpkgs-overlays=$PWD/nixpkgs/overlays.nix"
-    ]}"
+  NIX_PATH = pkgs.lib.concatStringsSep ":" [
+    "nixpkgs=${pkgs.path}"
+    ("nixpkgs-overlays=" + pkgs.writeText "overlays.nix" ''
+      import ${inputs.self + "/nixpkgs/overlays.nix"} ++
+      import ${inputs.julm-nix + "/nixpkgs/overlays.nix"}
+    '')
+  ];
 
-    # Since the .envrc calls this shellHook
-    # the EXIT trap cannot be freely used
-    # because it's already used by direnv,
-    # hence shred at startup, which is not ideal.
-    sourcephile-shred-tmp
+  shellHook = ''
+    echo >&2 "nix: running shellHook"
 
-    ${modules.nix-shell.shellHook}
+    ${shell.nix-shell.shellHook}
 
     # gpg
+    export GNUPGHOME=$(realpath -e ${shell.gnupg.gnupgHome});
     export GPG_TTY=$(tty)
     gpg-connect-agent updatestartuptty /bye >/dev/null
-  '';
+
+    # pass
+    export PASSWORD_STORE_DIR="$PWD"
+  '' + shellHook;
 }