+{ inputs, pkgs, shellHook ? "", ... }:
let
- nixpkgs = import .lib/nix/nixpkgs.nix;
- pkgs = import nixpkgs {
- config = {}; # Make the config pure, ignoring user's config.
- overlays = import ./overlays.nix;
- };
- lib = pkgs.lib;
- nixos = pkgs.nixos {};
-
# Configuration of shell/modules/
- configuration = {config, ...}: {
+ # to expand shellHook and buildInputs of this shell.nix
+ shellConfig = { ... }: {
imports = [
+ shell/gnupg.nix
];
- nix = {
- nixConf = ''
- auto-optimise-store = true
- '';
- };
- nix-plugins = {
- enable = true;
- };
gnupg = {
enable = true;
- gnupgHome = toString ../sec/gnupg;
- keys = import shell/gnupg/keys.nix;
+ gnupgHome = "../sec/gnupg";
+ gpgExtraConf = ''
+ # julm@sourcephile.fr
+ trusted-key 0xB2450D97085B7B8C
+ default-key 0x4FE467034C11017B429BAC53A58CD81C3863926F
+ '';
+ gpgAgentExtraConf = ''
+ #pretend-request-origin remote
+ #extra-socket ${toString ./.}/S.gpg-agent.extra
+ #log-file ${toString ./.}/gpg-agent.log
+ #no-grab
+ #debug-level expert
+ #allow-loopback-pinentry
+ '';
};
+ /*
+ openssl = {
+ enable = true;
+ opensslHome = "../sec/openssl";
+ certificates = import shell/x509.nix;
+ };
+ */
openssh = {
enable = true;
sshConf = ''
- Ciphers aes256-gcm@openssh.com,aes128-gcm@openssh.com
- Compression yes
- CompressionLevel 4
+ Ciphers aes256-gcm@openssh.com,aes128-gcm@openssh.com,aes256-ctr
+ Compression no
+ #CompressionLevel 4
ControlMaster auto
- ControlPath ${builtins.toString .sec/ssh}/ssh-%h-%p-%r.socket
+ ControlPath .ssh-%h-%p-%r.socket
HashKnownHosts no
- SSAPIAuthentication no
+ #SSAPIAuthentication no
SendEnv LANG LC_*
StrictHostKeyChecking yes
- UserKnownHostsFile ${builtins.toString .sec/ssh/known_hosts}
+ #UserKnownHostsFile ''${inputs.secrets + "/ssh/known_hosts"}
'';
};
+ virtualbox = {
+ enable = false;
+ };
};
# Using modules enables to separate specific configurations
# from reusable code in shell/modules.nix and shell/modules/
# which may find its way in another git repository one day.
- modules =
- (import shell/modules.nix {
- inherit pkgs lib;
- modules = [ configuration ];
- }).config;
+ shell = (pkgs.lib.evalModules {
+ modules = [
+ shellConfig
+ { config._module.args = { inherit inputs pkgs; }; }
+ ] ++ map import (pkgs.lib.findFiles ".*\\.nix" shell/modules);
+ }).config;
in
-pkgs.stdenv.mkDerivation {
+pkgs.mkShell {
name = "sourcephile-nix";
src = null;
#preferLocalBuild = true;
#allowSubstitutes = false;
- buildInputs = modules.nix-shell.buildInputs ++ [
- nixpkgs
- nixos.nixos-generate-config
- nixos.nixos-install
- nixos.nixos-enter
+ buildInputs = shell.nix-shell.buildInputs ++ [
+ (pkgs.nixos [ ]).nixos-generate-config
+ (pkgs.nixos [ ]).nixos-install
+ (pkgs.nixos [ ]).nixos-enter
#pkgs.binutils
pkgs.coreutils
pkgs.cryptsetup
pkgs.curl
#pkgs.direnv
- #pkgs.dnsutils
+ pkgs.dnsutils
#pkgs.dropbear
pkgs.e2fsprogs
pkgs.git
pkgs.htop
#pkgs.inetutils
pkgs.ipcalc
+ #pkgs.iputils
pkgs.less
pkgs.libfaketime
+ pkgs.ldns
+ #pkgs.ldns.examples
#pkgs.mailutils
pkgs.man
pkgs.mdadm
pkgs.gptfdisk
pkgs.ncdu
pkgs.ncurses
- pkgs.nixops
+ #pkgs.nixops
#pkgs.openssl
pkgs.pass
pkgs.procps
+ pkgs.rsync
#pkgs.rxvt_unicode.terminfo
#pkgs.sqlite
pkgs.sqlite
- pkgs.sudo
+ #pkgs.sudo
pkgs.tig
pkgs.time
#pkgs.tmux
pkgs.tree
pkgs.utillinux
- pkgs.vim
+ #pkgs.vim
#pkgs.virtualbox
pkgs.which
- pkgs.xdg_utils
- pkgs.zfs
+ pkgs.xdg-utils
pkgs.fio
pkgs.strace
pkgs.utillinux
#pkgs.zfstools
+ pkgs.linuxPackages.perf
+ #pkgs.go2nix
+ pkgs.wireguard-tools
+ pkgs.stun
+ pkgs.mkpasswd
+ #pkgs.ubootTools
+ #pkgs.hydra-unstable
];
#enableParallelBuilding = true;
- shellHook = ''
- echo >&2 "nix: running shellHook"
-
- ${modules.nix-shell.shellHook}
-
- # nix
- export NIX_PATH="nixpkgs=${nixpkgs}"
- NIX_PATH+=":nixpkgs-overlays="$PWD"/overlays"
- #NIX_PATH+=""
-
- # executables
- PATH_NIX=$(dirname $(readlink -e ~/.nix-profile/bin/nix))
- PATH_NIXOS=/run/wrappers/bin
- PATH_FHS="$PWD"/.lib/nix/fhs-bin
- PATH_FHS_VBOX="$PWD"/.lib/fhs-vbox-bin
- export PATH="$PATH_NIXOS:$PATH_FHS_VBOX:$PATH_FHS:$PATH:$PATH_NIX"
- # NOTE: sudo needs to be own by root with the setuid bit,
- # but this won't be the case for the sudo provided by Nix outside NixOS,
- # hence the addition of $PATH_FHS in shellHook
- # to provide the host system's sudo.
- # WARNING: beware that sudo may reset the environment,
- # and especially PATH, to some system's default.
-
- # locales
- export LANG=fr_FR.UTF-8
- export LC_CTYPE=fr_FR.UTF-8
+ NIX_PATH = pkgs.lib.concatStringsSep ":" [
+ "nixpkgs=${pkgs.path}"
+ ("nixpkgs-overlays=" + pkgs.writeText "overlays.nix" ''
+ import ${inputs.self + "/nixpkgs/overlays.nix"} ++
+ import ${inputs.julm-nix + "/nixpkgs/overlays.nix"}
+ '')
+ ];
- # password-store
- export PASSWORD_STORE_DIR="$PWD"/../sec/pass
+ shellHook = ''
+ echo >&2 "nix: running shellHook"
- # git
- gitdir="$PWD"/.git
- test ! -f "$gitdir" || while IFS=" :" read -r hdr gitdir; do [ "$hdr" != gitdir ] || break; done <"$gitdir"
- ln -fnsr \
- "$PWD"/.lib/git/hooks/prepare-commit-msg--longuest-common-prefix \
- "$gitdir"/hooks/prepare-commit-msg
+ ${shell.nix-shell.shellHook}
- # nixops
- #export NIXOPS_DEPLOYMENT="staging"
- export NIXOPS_STATE="$PWD"/.sec/nixops/state.nixops
- NIXOPS_OPTS+=" --show-trace"
- export NIXOPS_OPTS
+ # gpg
+ export GNUPGHOME=$(realpath -e ${shell.gnupg.gnupgHome});
+ export GPG_TTY=$(tty)
+ gpg-connect-agent updatestartuptty /bye >/dev/null
- # disnix
- #export DISNIXOS_USE_NIXOPS=1
- #export DISNIX_CLIENT_INTERFACE=disnix-nixops-client
- #export DISNIX_PROFILE=default
- #export DISNIX_TARGET_PROPERTY=hostname
- #export DYSNOMIA_STATEDIR="$PWD"/.sec/dysnomia
- '';
+ # pass
+ export PASSWORD_STORE_DIR="$PWD"
+ '' + shellHook;
}