losurdo: update system.stateVersion
[sourcephile-nix.git] / hosts / mermet / croc.nix
index 885520877e347d5e20ffc912dbb77b63e89cd70b..5a95f0c17cab12b7916f0424114f3f49801ae7df 100644 (file)
@@ -1,18 +1,18 @@
-{ inputs, pkgs, lib, config, ... }:
+{ lib, config, ... }:
 let
   inherit (config.services) croc;
 in
 {
-networking.nftables.ruleset = ''
-  table inet filter {
-    chain input-net {
-      tcp dport {${lib.concatMapStringsSep "," toString croc.ports}} counter accept comment "croc"
+  networking.nftables.ruleset = ''
+    table inet filter {
+      chain input-net {
+        tcp dport {${lib.concatMapStringsSep "," toString croc.ports}} counter accept comment "croc"
+      }
     }
-  }
-'';
-services.croc = {
-  enable = true;
-  pass = builtins.readFile (inputs.secrets + "/croc/pass");
-  #debug = true;
-};
+  '';
+  services.croc = {
+    enable = true;
+    pass = builtins.readFile croc/pass.clear;
+    #debug = true;
+  };
 }