#postfix/sourcephile.fr.nix
];
users.groups.acme.members = [ postfix.user ];
-/*
networking.nftables.ruleset = ''
- add rule inet filter net2fw tcp dport 25 counter accept comment "SMTP"
- add rule inet filter net2fw tcp dport 465 counter accept comment "submissions"
+ #add rule inet filter net2fw tcp dport 25 counter accept comment "SMTP"
+ #add rule inet filter net2fw tcp dport 465 counter accept comment "submissions"
add rule inet filter fw2net meta skuid ${postfix.user} tcp dport 25 counter accept comment "SMTP"
'';
-*/
services.postfix = {
enable = true;
networksStyle = "host";
tls_server_sni_maps = "hash:/run/keys/postfix-sni";
# Only explicitely aliased accounts have a mail, not all the passwd
- local_recipient_maps = "$alias_maps";
+ #local_recipient_maps = "$alias_maps";
# Note that the local transport rewrites the envelope recipient
# according to the alias_maps, and thus the aliasing is transparent
# to the nexthop (eg. dovecot)
- #local_transport = local:$myhostname
+ local_transport = "local:$myhostname";
# No console bell on new mail
biff = false;
forward_path = [
virtual_mailbox_domains = [];
# Completed by the postfix/*.nix
virtual_mailbox_maps = [
- "hash:/etc/postfix/virtual"
+ #"hash:/etc/postfix/virtual"
];
#virtual_transport = "lmtp:unix:private/dovecot-lmtp";
/*
# There is no fallback
fallback_transport = "";
};
+ transport = ''
+ sourcephile.wg local:losurdo
+ '';
virtualMapType = "hash";
masterConfig =
let