losurdo: gitolite: udpate
[sourcephile-nix.git] / hosts / losurdo / postfix.nix
index 45fce73416e0c78af182db5cdc487fb880127632..42f9dc344b5f2ad81cbb4ef20172d74468f668dc 100644 (file)
@@ -10,13 +10,11 @@ imports = [
   #postfix/sourcephile.fr.nix
 ];
 users.groups.acme.members = [ postfix.user ];
-/*
 networking.nftables.ruleset = ''
-  add rule inet filter net2fw tcp dport 25 counter accept comment "SMTP"
-  add rule inet filter net2fw tcp dport 465 counter accept comment "submissions"
+  #add rule inet filter net2fw tcp dport 25 counter accept comment "SMTP"
+  #add rule inet filter net2fw tcp dport 465 counter accept comment "submissions"
   add rule inet filter fw2net meta skuid ${postfix.user} tcp dport 25 counter accept comment "SMTP"
 '';
-*/
 services.postfix = {
   enable = true;
   networksStyle = "host";
@@ -211,11 +209,11 @@ services.postfix = {
     tls_server_sni_maps = "hash:/run/keys/postfix-sni";
 
     # Only explicitely aliased accounts have a mail, not all the passwd
-    local_recipient_maps = "$alias_maps";
+    #local_recipient_maps = "$alias_maps";
     # Note that the local transport rewrites the envelope recipient
     # according to the alias_maps, and thus the aliasing is transparent
     # to the nexthop (eg. dovecot)
-    #local_transport = local:$myhostname
+    local_transport = "local:$myhostname";
     # No console bell on new mail
     biff = false;
     forward_path = [
@@ -229,7 +227,7 @@ services.postfix = {
     virtual_mailbox_domains = [];
     # Completed by the postfix/*.nix
     virtual_mailbox_maps = [
-      "hash:/etc/postfix/virtual"
+      #"hash:/etc/postfix/virtual"
     ];
     #virtual_transport = "lmtp:unix:private/dovecot-lmtp";
     /*
@@ -240,6 +238,9 @@ services.postfix = {
     # There is no fallback
     fallback_transport = "";
   };
+  transport = ''
+    sourcephile.wg local:losurdo
+  '';
   virtualMapType = "hash";
   masterConfig =
     let