{
imports = [
./modules.nix
+ ./options.nix
(inputs.julm-nix + "/nixos/profiles/security.nix")
defaults/predictable-interface-names.nix
];
#binaryCaches = lib.mkForce [];
extraOptions = ''
'';
- autoOptimiseStore = lib.mkDefault true;
+ settings.auto-optimise-store = lib.mkDefault true;
# Use gc.automatic to keep disk space under control.
gc.automatic = lib.mkDefault true;
gc.dates = lib.mkDefault "weekly";
gc.options = lib.mkDefault "--delete-older-than 30d";
# Setting NIX_PATH is useless now that flake.nix are used.
- nixPath = lib.mkForce [];
+ nixPath = [];
};
environment.variables.NIXPKGS_CONFIG = lib.mkForce "";
usePredictableInterfaceNames = true;
};
-services.logrotate = {
- enable = true;
- paths = {
- btmp = {
- path = "/var/log/btmp";
- frequency = "monthly";
- keep = 6;
- extraConfig = ''
- create 0660 root utmp
- '';
- };
- wtmp = {
- path = "/var/log/wtmp";
- frequency = "monthly";
- keep = 6;
- extraConfig = ''
- create 0664 root utmp
- '';
- };
- };
-};
+services.logrotate.enable = true;
services.openssh.enable = true;
nethogs
nload
nmon
+ pciutils # Not supported by a few hardwares
+ psmisc
pv
- rdfind
+ #rdfind
smem
tcpdump
tmux
tree
usbutils
- vim
+ #vim
which
#dnsutils
#ntop