public-inbox: fix cc not found
[sourcephile-nix.git] / nixos / defaults.nix
index 873864beb97971b4cc28507683c2fa2b63cff4cf..db52e5bbf32846f50e801cd3209a3d89f461375f 100644 (file)
@@ -5,6 +5,7 @@ in
 {
 imports = [
   ./modules.nix
+  ./options.nix
   (inputs.julm-nix + "/nixos/profiles/security.nix")
   defaults/predictable-interface-names.nix
 ];
@@ -12,13 +13,13 @@ nix = {
   #binaryCaches = lib.mkForce [];
   extraOptions = ''
   '';
-  autoOptimiseStore = lib.mkDefault true;
+  settings.auto-optimise-store = lib.mkDefault true;
   # Use gc.automatic to keep disk space under control.
   gc.automatic = lib.mkDefault true;
   gc.dates = lib.mkDefault "weekly";
   gc.options = lib.mkDefault "--delete-older-than 30d";
   # Setting NIX_PATH is useless now that flake.nix are used.
-  nixPath = lib.mkForce [];
+  nixPath = [];
 };
 environment.variables.NIXPKGS_CONFIG = lib.mkForce "";
 
@@ -60,27 +61,7 @@ networking = {
   usePredictableInterfaceNames = true;
 };
 
-services.logrotate = {
-  enable = true;
-  paths = {
-    btmp = {
-      path = "/var/log/btmp";
-      frequency = "monthly";
-      keep = 6;
-      extraConfig = ''
-        create 0660 root utmp
-      '';
-    };
-    wtmp = {
-      path = "/var/log/wtmp";
-      frequency = "monthly";
-      keep = 6;
-      extraConfig = ''
-        create 0664 root utmp
-      '';
-    };
-  };
-};
+services.logrotate.enable = true;
 
 services.openssh.enable = true;
 
@@ -104,14 +85,16 @@ environment.systemPackages = with pkgs; [
   nethogs
   nload
   nmon
+  pciutils # Not supported by a few hardwares
+  psmisc
   pv
-  rdfind
+  #rdfind
   smem
   tcpdump
   tmux
   tree
   usbutils
-  vim
+  #vim
   which
   #dnsutils
   #ntop