mermet: miniflux: enable DynamicUser=
[sourcephile-nix.git] / tests.nix
index 768019f0157cfce98b17efb7f90ad0525b30b439..d280486644f7904ff91b59a1df4e4003e282eab5 100644 (file)
--- a/tests.nix
+++ b/tests.nix
@@ -1,29 +1,30 @@
 # Run with : nix run -f tests.nix
 # Debug with : nix -L run -f tests.nix driver -c nixos-test-driver
-{ system ? builtins.currentSystem,
-  config ? {},
-  overlays ? nixpkgs/overlays.nix,
-  pkgs ? import <nixpkgs> { inherit system config overlays; },
-  lib ? pkgs.lib,
+{ system ? builtins.currentSystem
+, config ? { }
+, overlays ? nixpkgs/overlays.nix
+, pkgs ? import <nixpkgs> { inherit system config overlays; }
+,
 }:
 
-let nixosTest =
-  (import (pkgs.path + /nixos/lib/testing-python.nix)) {
-    inherit system pkgs;
-    extraConfigurations = [
-      ({ lib, ... }: {
-        # Propagate pkgs and its overlays to the VM,
-        # instead of reloading nixpkgs.
-        config.nixpkgs.pkgs = lib.mkDefault pkgs;
-        config.documentation.enable = false;
-      })
-    ];
-  };
+let
+  nixosTest =
+    (import (pkgs.path + /nixos/lib/testing-python.nix)) {
+      inherit system pkgs;
+      extraConfigurations = [
+        ({ lib, ... }: {
+          # Propagate pkgs and its overlays to the VM,
+          # instead of reloading nixpkgs.
+          config.nixpkgs.pkgs = lib.mkDefault pkgs;
+          config.documentation.enable = false;
+        })
+      ];
+    };
 in
 
 nixosTest.makeTest {
   nodes = {
-    mermet = {pkgs, ...}@attrs: {};
+    mermet = { ... }: { };
   };
 
   #enableOCR = true;