# Run with : nix run -f tests.nix
# Debug with : nix -L run -f tests.nix driver -c nixos-test-driver
-{ system ? builtins.currentSystem,
- config ? {},
- overlays ? nixpkgs/overlays.nix,
- pkgs ? import <nixpkgs> { inherit system config overlays; },
- lib ? pkgs.lib,
+{ system ? builtins.currentSystem
+, config ? { }
+, overlays ? nixpkgs/overlays.nix
+, pkgs ? import <nixpkgs> { inherit system config overlays; }
+,
}:
-let nixosTest =
- (import (pkgs.path + /nixos/lib/testing-python.nix)) {
- inherit system pkgs;
- extraConfigurations = [
- ({ lib, ... }: {
- # Propagate pkgs and its overlays to the VM,
- # instead of reloading nixpkgs.
- config.nixpkgs.pkgs = lib.mkDefault pkgs;
- config.documentation.enable = false;
- })
- ];
- };
+let
+ nixosTest =
+ (import (pkgs.path + /nixos/lib/testing-python.nix)) {
+ inherit system pkgs;
+ extraConfigurations = [
+ ({ lib, ... }: {
+ # Propagate pkgs and its overlays to the VM,
+ # instead of reloading nixpkgs.
+ config.nixpkgs.pkgs = lib.mkDefault pkgs;
+ config.documentation.enable = false;
+ })
+ ];
+ };
in
nixosTest.makeTest {
nodes = {
- mermet = {pkgs, ...}@attrs: {};
+ mermet = { ... }: { };
};
#enableOCR = true;