losurdo: transmission: open RPC on input-intra
[sourcephile-nix.git] / hosts / mermet / public-inbox.nix
index d1674891f2bb7c65c33ebaf97bacb5ee8b65fb54..2f663c5fed135ef8c477b7ed13460b2deb4e3942 100644 (file)
@@ -27,8 +27,14 @@ security.acme.certs."${domain}" = {
   postRun = "systemctl try-restart public-inbox-nntpd public-inbox-imapd";
 };
 networking.nftables.ruleset = ''
-  add rule inet filter net2fw tcp dport ${toString public-inbox.nntp.port} counter accept comment "NNTPS"
-  add rule inet filter net2fw tcp dport 1993 counter accept comment "IMAPS"
+  table inet filter {
+    chain input-net {
+      tcp dport ${toString public-inbox.nntp.port} counter accept comment "public-inbox: NNTPS"
+      tcp dport 1993 counter accept comment "public-inbox: IMAPS"
+    }
+    chain output-net {
+    }
+  }
 '';
 fileSystems."/var/lib/public-inbox" = {
   device = "rpool/var/public-inbox";
@@ -71,6 +77,7 @@ services.public-inbox = {
     css = [ "href=https://mails.${domain}/style/light.css" ];
     nntpserver = [ "nntps://news.${domain}" ];
     wwwlisting = "match=domain";
+    #imapserver = [ "mails.${domain}" ];
   };
   mda = {
     enable = true;