postRun = "systemctl try-restart public-inbox-nntpd public-inbox-imapd";
};
networking.nftables.ruleset = ''
- add rule inet filter net2fw tcp dport ${toString public-inbox.nntp.port} counter accept comment "NNTPS"
- add rule inet filter net2fw tcp dport 1993 counter accept comment "IMAPS"
+ table inet filter {
+ chain input-net {
+ tcp dport ${toString public-inbox.nntp.port} counter accept comment "public-inbox: NNTPS"
+ tcp dport 1993 counter accept comment "public-inbox: IMAPS"
+ }
+ chain output-net {
+ }
+ }
'';
fileSystems."/var/lib/public-inbox" = {
device = "rpool/var/public-inbox";
css = [ "href=https://mails.${domain}/style/light.css" ];
nntpserver = [ "nntps://news.${domain}" ];
wwwlisting = "match=domain";
+ #imapserver = [ "mails.${domain}" ];
};
mda = {
enable = true;