};
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
-boot.kernel = {
- sysctl = {
- "vm.swappiness" = 10;
- "vm.vfs_cache_pressure" = 50;
- };
-};
+# https://insanity.industries/post/sata-power-consumption/
+services.udev.extraRules = ''
+ SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
+'';
boot.loader = {
grub = {
copyKernels = true;
configurationLimit = 3;
efiSupport = true;
- # Vecause canTouchEfiVariables doesn't work on this system
+ # Because canTouchEfiVariables doesn't work on this system
efiInstallAsRemovable = true;
devices = [
# Completed in the importing configuration
"console=ttyS0,115200n8"
"console=ttyS1,115200n8"
"console=tty0"
- # Use arc_summary to print stats
- "zfs.zfs_arc_max=${toString (1000 * 1024 * 1024)}" # bytes
];
+# rtlwifi/rtl8188efw.bin
+hardware.enableRedistributableFirmware = true;
+
environment.systemPackages = with pkgs; [
pciutils
- #flashrom
nvme-cli
];
}