nginx: change paths and config on losurdo
[sourcephile-nix.git] / nixos / profiles / hardware / dl10j.nix
index 00db6cc1c72d68044e643ffe6610092a40b64f40..bb36a00737059cfa6527fb2be34b209df415a8ef 100644 (file)
@@ -8,12 +8,10 @@ nix = {
 };
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
-boot.kernel = {
-  sysctl = {
-    "vm.swappiness" = 10;
-    "vm.vfs_cache_pressure" = 50;
-  };
-};
+# https://insanity.industries/post/sata-power-consumption/
+services.udev.extraRules = ''
+  SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
+'';
 
 boot.loader = {
   grub = {
@@ -22,7 +20,7 @@ boot.loader = {
     copyKernels = true;
     configurationLimit = 3;
     efiSupport = true;
-    # Vecause canTouchEfiVariables doesn't work on this system
+    # Because canTouchEfiVariables doesn't work on this system
     efiInstallAsRemovable = true;
     devices = [
       # Completed in the importing configuration
@@ -74,13 +72,13 @@ boot.kernelParams = [
   "console=ttyS0,115200n8"
   "console=ttyS1,115200n8"
   "console=tty0"
-  # Use arc_summary to print stats
-  "zfs.zfs_arc_max=${toString (1000 * 1024 * 1024)}" # bytes
 ];
 
+# rtlwifi/rtl8188efw.bin
+hardware.enableRedistributableFirmware = true;
+
 environment.systemPackages = with pkgs; [
   pciutils
-  #flashrom
   nvme-cli
 ];
 }