losurdo: enable nix-serve only over wg-intra
[sourcephile-nix.git] / nixos / profiles / hardware / apu2e4.nix
index af318228752fa1e5e1b30005346e1ca01cb58aeb..63d0f0bf21e8245027ec81bb40459a66ad592701 100644 (file)
@@ -1,26 +1,23 @@
 { pkgs, lib, config, ... }:
 {
 hardware.cpu.amd.updateMicrocode = true;
-nix = {
-  # Too CPU hungry for the APU2, for too little Mio saved
-  autoOptimiseStore = false;
-  maxJobs = 4;
-};
+
+# Too CPU hungry for this hardware, for too little Mio saved
+nix.autoOptimiseStore = false;
+
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
-boot.kernel = {
-  sysctl = {
-    "vm.swappiness" = 10;
-    "vm.vfs_cache_pressure" = 50;
-  };
-};
+# https://insanity.industries/post/sata-power-consumption/
+services.udev.extraRules = ''
+  SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
+'';
 
 boot.loader = {
   grub = {
     enable = true;
     version = 2;
     copyKernels = true;
-    configurationLimit = 3;
+    configurationLimit = 1;
     # efiSupport = true;
     # In case canTouchEfiVariables doesn't work
     #efiInstallAsRemovable = true;
@@ -52,9 +49,9 @@ boot.initrd = {
     "uas"
     # Ethernet driver
     "igb"
-    # Made the AES modules available at initrd,
+    # Make the AES modules available at initrd,
     # to speedup the deciphering of the root.
-    "aes_x86_64"
+    #"aes_x86_64"
     "aesni_intel"
     "cryptd"
   ];
@@ -68,7 +65,7 @@ boot.kernelParams = [
   #"console=tty0"
   "console=ttyS0,115200n8"
   # Use arc_summary to print stats
-  "zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
+  #"zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
 ];
 
 environment.systemPackages = [