syncoid: polish conf while debugging
[sourcephile-nix.git] / nixos / profiles / hardware / apu2e4.nix
index af318228752fa1e5e1b30005346e1ca01cb58aeb..b8070a630067d46f34bfade85f0e27867f3c2567 100644 (file)
@@ -8,19 +8,17 @@ nix = {
 };
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
-boot.kernel = {
-  sysctl = {
-    "vm.swappiness" = 10;
-    "vm.vfs_cache_pressure" = 50;
-  };
-};
+# https://insanity.industries/post/sata-power-consumption/
+services.udev.extraRules = ''
+  SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
+'';
 
 boot.loader = {
   grub = {
     enable = true;
     version = 2;
     copyKernels = true;
-    configurationLimit = 3;
+    configurationLimit = 1;
     # efiSupport = true;
     # In case canTouchEfiVariables doesn't work
     #efiInstallAsRemovable = true;
@@ -68,7 +66,7 @@ boot.kernelParams = [
   #"console=tty0"
   "console=ttyS0,115200n8"
   # Use arc_summary to print stats
-  "zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
+  #"zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
 ];
 
 environment.systemPackages = [