-{ inputs, pkgs, lib, config, ... }:
+{ inputs, pkgs, lib, config, host, ... }:
let
inherit (lib) types;
inherit (config) networking;
charset UTF-8;
types {
text/html html5;
- text/plain md;
text/plain dump;
}
'' +
lib.concatStringsSep "\n" (lib.attrValues {
default = ''
- default_type application/octet-stream;
+ #default_type application/octet-stream;
root /var/lib/nginx;
'';
security = ''
'';
});
appendConfig = ''
- worker_processes ${toString config.nix.maxJobs};
+ worker_processes ${toString host.CPUs};
'';
};
};