nix: update to latest nixos-unstable
[sourcephile-nix.git] / nixos / profiles / services / nginx.nix
index 9cbfedb6b49ae9addfd5587ab78a2ad29923403e..4d721daf607fcd9a61406bfcf66b381eab259c9b 100644 (file)
@@ -1,4 +1,4 @@
-{ inputs, pkgs, lib, config, ... }:
+{ inputs, pkgs, lib, config, host, ... }:
 let
   inherit (lib) types;
   inherit (config) networking;
@@ -101,13 +101,12 @@ services.nginx = {
     charset UTF-8;
     types {
       text/html html5;
-      text/plain md;
       text/plain dump;
     }
     '' +
     lib.concatStringsSep "\n" (lib.attrValues {
       default = ''
-        default_type application/octet-stream;
+        #default_type application/octet-stream;
         root /var/lib/nginx;
       '';
       security = ''
@@ -202,7 +201,7 @@ services.nginx = {
       '';
     });
   appendConfig = ''
-    worker_processes ${toString config.nix.maxJobs};
+    worker_processes ${toString host.CPUs};
   '';
 };
 };