private: use .cred instead of .secret
[sourcephile-nix.git] / shell / gnupg.nix
index 59af39d11612fcf14c442cc4857a1967212a2db1..7f1b15b4785c2642a506c9a465ea5fa0ef289059 100644 (file)
@@ -1,4 +1,4 @@
-{ flakes, pkgs, lib, config, ... }:
+{ inputs, pkgs, lib, config, ... }:
 {
 gnupg.keys = {
 "Julien Moutinho <julm@sourcephile.fr>" = {
@@ -29,15 +29,15 @@ gnupg.keys = {
 };
 } // lib.listToAttrs (
   let domain = "sourcephile.fr"; in
-  builtins.map (machine: lib.nameValuePair "root@${machine}.${domain}" {
-  uid = "root@${machine}.${domain}";
+  builtins.map (host: lib.nameValuePair "root@${host}.${domain}" {
+  uid = "root@${host}.${domain}";
   algo = "rsa4096";
   expire = "0";
   usage = ["cert" "sign"];
-  passPath = "machines/${machine}/root/key.pass";
+  passPath = "hosts/${host}/gnupg/root";
   subKeys = [
     { algo = "rsa4096"; expire = "0"; usage = ["encrypt"]; }
   ];
   backupRecipients = [""];
-}) (builtins.attrNames flakes.self.nixosConfigurations));
+}) (builtins.attrNames inputs.self.nixosConfigurations));
 }