zfs: avoid mismatch between zfs-user and zfs-kmod
[sourcephile-nix.git] / nixos / defaults.nix
index 22fe8f8518093e4a8eca8684af4786d7ddc01871..00c90e5402a5557b864e3c0ffb40b610caf12ca3 100644 (file)
@@ -1,4 +1,4 @@
-{ flakes, pkgs, lib, config, ... }:
+{ inputs, pkgs, lib, config, ... }:
 let inherit (lib) types;
     inherit (config.networking) hostName domain;
 in
@@ -25,8 +25,8 @@ nix = {
     "nixpkgs=/etc/nixpkgs:nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
   ];
 };
-environment.etc."nixpkgs".source = flakes.nixpkgs;
-environment.etc."nixpkgs-overlays".source = flakes.self + "/nixpkgs";
+environment.etc."nixpkgs".source = pkgs.path;
+environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
 
 nixpkgs = {
   config = {
@@ -39,7 +39,6 @@ nixpkgs = {
     };
     */
   };
-  overlays = import (flakes.self + "/nixpkgs/overlays.nix");
 };
 
 documentation.nixos = {
@@ -95,9 +94,9 @@ services = {
   journald = {
     extraConfig = ''
       Compress=true
-      MaxRetentionSec=3month
+      MaxRetentionSec=1month
       Storage=persistent
-      SystemMaxUse=500M
+      SystemMaxUse=128M
     '';
   };
 };
@@ -124,6 +123,7 @@ environment.systemPackages = with pkgs; [
   nmon
   pv
   swaplist
+  stress
   tcpdump
   tmux
   tree
@@ -179,5 +179,6 @@ programs = {
   };
   mosh.enable = true;
   mtr.enable = true;
+  traceroute.enable = true;
 };
 }