-{ pkgs, lib, config, ... }:
+{ pkgs, lib, config, host, ... }:
{
hardware.cpu.amd.updateMicrocode = true;
nix = {
# Too CPU hungry for the APU2, for too little Mio saved
autoOptimiseStore = false;
- maxJobs = 4;
+ maxJobs = host.CPUs / 2;
};
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
-boot.kernel = {
- sysctl = {
- "vm.swappiness" = 10;
- "vm.vfs_cache_pressure" = 50;
- };
-};
+# https://insanity.industries/post/sata-power-consumption/
+services.udev.extraRules = ''
+ SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
+'';
boot.loader = {
grub = {
"uas"
# Ethernet driver
"igb"
- # Made the AES modules available at initrd,
+ # Make the AES modules available at initrd,
# to speedup the deciphering of the root.
- "aes_x86_64"
+ #"aes_x86_64"
"aesni_intel"
"cryptd"
];
#"console=tty0"
"console=ttyS0,115200n8"
# Use arc_summary to print stats
- "zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
+ #"zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
];
environment.systemPackages = [