shell: fix nixos-enter
[sourcephile-nix.git] / nixos / profiles / systems / crossCompilation.nix
index 0899a0e67b157e6090fb1e5917fd51086440ef49..63099ab80de2225e3527c34ffbf76eea69c5c802 100644 (file)
@@ -1,60 +1,11 @@
-{ pkgs, lib, config, ... }:
 {
-nixpkgs.overlays = [
-  (final: super: {
-    # TODO: remove after liburing-2.1
-    liburing = super.liburing.overrideAttrs (old: {
-      src = super.fetchgit {
-        url    = "http://git.kernel.dk/${old.pname}";
-        rev    = "cb350a8989adbd65db574325d9a86d5437d800da";
-        sha256 = "sha256-ZMev2RjiswuR9seVwHbnVUtnpaPW/XJbelBgvIuYiGg=";
-      };
-    });
-    gnupg = super.gnupg.override {
-      # Wants polkit which wants spidermonkey (slow to compile)
-      pcsclite = null;
-    };
-    systemd = super.systemd.override {
-      # Wants tpm2-tss which does not cross-compile
-      withTpm2Tss = false;
-      # Does not cross-compile :(
-      withEfi = false;
-    };
-    # https://logs.nix.samueldr.com/nixos/2019-07-23#2416964;
-    xorg = super.xorg.overrideScope' (ofinal: osuper: {
-      fontadobe100dpi = final.hello;
-      fontadobe75dpi = final.hello;
-      fontcursormisc = final.hello;
-      fontmiscmisc = final.hello;
-    });
-    # Perl's ModuleBuild does not cross-compile
-    # https://github.com/NixOS/nixpkgs/issues/66741#issuecomment-944831760
-    xdg-utils = final.hello;
-    procmail = final.hello;
-    noto-fonts-emoji = final.hello;
-    x11_ssh_askpass = final.hello;
-    dconf = super.dconf.overrideAttrs (old: {
-      doCheck = false;
-    });
-    # Need gobject-instrospection which does not cross-compile
-    arandr = final.hello;
-    # Depends on judy which does not cross-compile
-    stress-ng = final.hello;
-    hwinfo = final.hello;
-    # Fails to cross-compile: perl5.34.0-IO-Tty-armv7l-unknown-linux-gnueabihf
-    mosh = final.hello;
-    # error: Error loading target specification:
-    # Could not find specification for target "armv7l-unknown-linux-gnueabihf".
-    # Run `rustc --print target-list` for a list of built-in targets
-    gparted = final.hello;
-  })
-];
-#environment.noXlibs = true;
-fonts.fontconfig.enable = false;
-# lesspipe does not cross-compile
-programs.less.enable = lib.mkForce false;
-programs.mosh.enable = false;
-programs.traceroute.enable = false;
-security.apparmor.enable = false;
-services.udisks2.enable = false;
+  nixpkgs.overlays = [
+    (finalPkgs: previousPkgs: {
+      # libx86emu-armv7l-unknown-linux-gnueabihf> /nix/store/r9h133c9m8f6jnlsqzwf89zg9w0w78s8-bash-5.2-p15/bin/bash: line 1: gcc: command not found
+      hwinfo = finalPkgs.hello;
+      # x11-ssh-askpass-armv7l-unknown-linux-gnueabihf> /build/imakeUMfSVM: line 1: syntax error: unexpected word (expecting ")")
+      x11_ssh_askpass = finalPkgs.hello;
+    })
+  ];
+  security.apparmor.enable = false;
 }