test -s "$PASSWORD_STORE_DIR/${cert.passPrefix}/${id}/key.pem.gpg" || {
info " generateKey: $PASSWORD_STORE_DIR/${cert.passPrefix}/${id}/key.pem.gpg"
${pkgs.openssl}/bin/openssl genrsa \
- -out stdout \
-rand /dev/urandom \
${toString cert.keySize} |
${pkgs.pass}/bin/pass insert --multiline "${cert.passPrefix}/${id}/key.pem"
options.openssl = {
enable = lib.mkEnableOption "Configuration of X.509 certificates";
opensslHome = lib.mkOption {
- type = types.path;
+ type = types.str;
default = "sec/openssl";
description = ''
OpenSSL's directory.