nix: rename { machines => hosts }
[sourcephile-nix.git] / shell / modules / tools / security / openssl.nix
index da4ee83724b2f90964d2986b33231441d7cf154c..722fa554247fe4f2a8cb9d7fd6bff7723cf95415 100644 (file)
@@ -10,7 +10,6 @@ let
     test -s "$PASSWORD_STORE_DIR/${cert.passPrefix}/${id}/key.pem.gpg" || {
       info "  generateKey: $PASSWORD_STORE_DIR/${cert.passPrefix}/${id}/key.pem.gpg"
       ${pkgs.openssl}/bin/openssl genrsa \
-       -out stdout \
        -rand /dev/urandom \
        ${toString cert.keySize} |
       ${pkgs.pass}/bin/pass insert --multiline "${cert.passPrefix}/${id}/key.pem"
@@ -149,7 +148,7 @@ in
 options.openssl = {
   enable = lib.mkEnableOption "Configuration of X.509 certificates";
   opensslHome = lib.mkOption {
-    type = types.path;
+    type = types.str;
     default = "sec/openssl";
     description = ''
       OpenSSL's directory.