log_format main '$remote_addr - $remote_user [$time_local] "$request" '
'$status $body_bytes_sent "$http_referer" '
'"$http_user_agent" "$http_x_forwarded_for"';
-
- log_format json escape=json
- '{'
- '"time_local":"$time_local",'
- '"remote_addr":"$remote_addr",'
- '"status": "$status",'
- '"request":"$request",'
- '"body_bytes_sent":"$body_bytes_sent",'
- '"http_referrer":"$http_referer",'
- '"http_user_agent":"$http_user_agent",'
- '"remote_user":"$remote_user",'
- '"request_time":"$request_time"'
- '}';
+ log_format json escape=json '{'
+ '"time_local":"$time_local",'
+ '"host":"$host",'
+ '"request":"$request",'
+ '"status":"$status",'
+ '"http_referrer":"$http_referer",'
+ '"remote_addr":"$remote_addr",'
+ '"remote_user":"$remote_user",'
+ '"msec":"$msec",'
+ '"body_bytes_sent":"$body_bytes_sent",'
+ '"bytes_sent":"$bytes_sent",'
+ '"http_user_agent":"$http_user_agent",'
+ '"request_length":"$request_length",'
+ '"request_method":"$request_method",'
+ '"request_time":"$request_time",'
+ '"request_uri":"$request_uri",'
+ '"server_protocol":"$server_protocol",'
+ '"ssl_protocol":"$ssl_protocol",'
+ '"upstream_addr":"$upstream_addr",'
+ '"upstream_connect_time":"$upstream_connect_time",'
+ '"upstream_response_time":"$upstream_response_time"'
+ '}';
charset UTF-8;
types {
text/html html5;
#proxy_cookie_path / "/; secure; HttpOnly; SameSite=strict";
'';
log = ''
- access_log /var/log/nginx/access.log main buffer=32k;
+ access_log /var/log/nginx/access.json json;
error_log /var/log/nginx/error.log warn;
open_log_file_cache max=1000 inactive=20s min_uses=2 valid=1m;
'';