carotte: move to carotte.wg
[sourcephile-nix.git] / hosts / losurdo / system.nix
index 3f8b750ca9a8d1acd976eda8d5666692df05355e..8b002fa9ddf9ecdfdab6d9debc5cea0d6f95cdb8 100644 (file)
@@ -9,21 +9,15 @@ in
 # You should change this only after NixOS release notes say you should.
 system.stateVersion = "19.09"; # Did you read the comment?
 
+nix.gc.dates = "weekly";
+nix.gc.options = "--delete-older-than 7d";
+
 # Avoid the use of systemd-run --user --scope tmux
 # and let mosh work smoothly.
 services.logind.killUserProcesses = false;
 
-nix.gc.dates = "weekly";
-nix.gc.options = "--delete-older-than 7d";
-nix.extraOptions = ''
-  secret-key-files = ${gnupg.secrets."nix/binary-cache-key/1".path}
-'';
-security.gnupg.secrets."nix/binary-cache-key/1" = {
-  systemdConfig = {
-    before = [ "nix-daemon.service" ];
-    wantedBy = [ "nix-daemon.service" ];
-  };
-};
+hardware.bluetooth.enable = true;
+#services.blueman.enable = true;
 
 documentation.nixos = {
   enable = false; # NOTE: useless on a server, and CPU intensive.
@@ -35,6 +29,7 @@ boot.kernelParams = [
 ];
 
 environment.systemPackages = with pkgs; [
+  bluez
   cryptsetup
   direnv
   f3