# You should change this only after NixOS release notes say you should.
system.stateVersion = "19.09"; # Did you read the comment?
+nix.gc.dates = "weekly";
+nix.gc.options = "--delete-older-than 7d";
+
# Avoid the use of systemd-run --user --scope tmux
# and let mosh work smoothly.
services.logind.killUserProcesses = false;
-nix.gc.dates = "weekly";
-nix.gc.options = "--delete-older-than 7d";
-nix.extraOptions = ''
- secret-key-files = ${gnupg.secrets."nix/binary-cache-key/1".path}
-'';
-security.gnupg.secrets."nix/binary-cache-key/1" = {
- systemdConfig = {
- before = [ "nix-daemon.service" ];
- wantedBy = [ "nix-daemon.service" ];
- };
-};
+hardware.bluetooth.enable = true;
+#services.blueman.enable = true;
documentation.nixos = {
enable = false; # NOTE: useless on a server, and CPU intensive.
];
environment.systemPackages = with pkgs; [
+ bluez
cryptsetup
direnv
f3