nix: update to latest julm-nix
[sourcephile-nix.git] / hosts / losurdo / ssh.nix
index 1b1d72cd5bcb3b46c0f1e36de8c93bfe45518c18..ea184f71c55bb5166bcfad59f40da32088ac562a 100644 (file)
@@ -1,5 +1,26 @@
 { pkgs, lib, config, hosts, ... }:
 {
+  services.openssh = {
+    openFirewall = true;
+    settings.X11Forwarding = true;
+  };
+  systemd.services.sshd.serviceConfig.LoadCredentialEncrypted = [
+    "host.key:${ssh/host.key.cred}"
+  ];
+  programs.ssh = {
+    extraConfig = ''
+    '';
+  };
+
+  boot.initrd.network.ssh = {
+    enable = true;
+    port = 2222;
+    authorizedKeys = config.users.users.root.openssh.authorizedKeys.keys;
+    hostKeys = [ "/root/initrd/ssh.key" ];
+    extraConfig = ''
+    '';
+  };
+
   systemd.services.ssh-mermet-reverse = {
     after = [ "network-online.target" ];
     wantedBy = [ "multi-user.target" ];
       RestartSec = "5s";
     };
   };
-  boot.initrd.network.ssh = {
-    enable = true;
-    port = 2222;
-    authorizedKeys = config.users.users.root.openssh.authorizedKeys.keys;
-    hostKeys = [ "/root/initrd/ssh.key" ];
-    extraConfig = ''
-  '';
-  };
-  services.openssh = {
-    openFirewall = true;
-    forwardX11 = true;
-  };
-  programs.ssh = {
-    extraConfig = ''
-      Compression = yes
-    '';
-  };
   services.upnpc.enable = true;
   services.upnpc.redirections =
     [