system:
-{ pkgs, lib, config, ... }:
+{ pkgs, lib, ... }:
let
systemConfig = { pkgs, ... }: {
# passwordless ssh server
};
security.sudo.wheelNeedsPassword = false;
- nix.trustedUsers = [ "root" "build" ];
+ nix.settings.trusted-users = [ "root" "build" ];
documentation.nixos.enable = false;
# builds.sr.ht-image-specific network settings
pkgs.gnupg
];
};
- qemuConfig = { pkgs, ... }: {
+ qemuConfig = { ... }: {
imports = [ systemConfig ];
fileSystems."/".device = "/dev/disk/by-label/nixos";
boot.initrd.availableKernelModules = [
diskSize = 16000;
format = "qcow2-compressed";
contents = [
- { source = pkgs.writeText "gitconfig" ''
+ {
+ source = pkgs.writeText "gitconfig" ''
[user]
name = builds.sr.ht
email = build@sr.ht