mermet: dovecot: sieve: try to fix extension handling
[sourcephile-nix.git] / hosts / losurdo / sourcehut.nix
index 1b6acaae7f32450dcd288b2987212f680d5deeb4..435ae1dc5de0e3f0f2a5bf3354f24087cc3ec70c 100644 (file)
@@ -33,8 +33,8 @@ security.gnupg.secrets = lib.genAttrs [
     "sourcehut/webhook-key"
     "sourcehut/oauth-client-secret"
   ] (p: {
-  systemdConfig.before = [ "metasrht.service" ];
-  systemdConfig.wantedBy = [ "metasrht.service" ];
+  systemdConfig.before = [ "metasrht.service" "gitsrht.service" ];
+  systemdConfig.wantedBy = [ "metasrht.service" "gitsrht.service" ];
 });
 services.minio = {
   enable = true;
@@ -72,7 +72,7 @@ services.sourcehut = {
         };
 
         security.sudo.wheelNeedsPassword = false;
-        nix.trustedUsers = [ "root" "build" ];
+        nix.settings.trusted-users = [ "root" "build" ];
         documentation.nixos.enable = false;
 
         # builds.sr.ht-image-specific network settings