public-inbox: fix to support the current nixpkgs
[sourcephile-nix.git] / shell.nix
index 5461dd212f7224e0c0560619a7b29063eba20cf4..adfa9bb563a2a0cf8f6e2e3fb2110566f2585dad 100644 (file)
--- a/shell.nix
+++ b/shell.nix
+{ inputs, pkgs, shellHook ? "", ... }:
 let
-  nixpkgs = import .lib/nix/nixpkgs.nix;
-  pkgs = import nixpkgs {
-    config   = {}; # Make the config pure, ignoring user's config.
-    overlays = import .lib/nixpkgs-commonsoft/build/overlays.nix;
-  };
-  commonsoft-nix-build-modules =
-    (import .lib/nixpkgs-commonsoft/build/modules.nix {
-      inherit pkgs;
-      inherit (pkgs) lib;
-      modules = [ ( import build/modules.nix ) ];
-    }).config;
-  /*
-  commonsoft-nix-build =
-    pkgs.stdenv.mkDerivation {
-      name = "commonsoft-nix-build";
-      preferLocalBuild = true;
-      allowSubstitutes = false;
-      inherit (pkgs) coreutils;
-      builder = pkgs.writeText "builder.sh" commonsoft-nix-build-modules.init.builder;
+  # Configuration of shell/modules/
+  # to expand shellHook and buildInputs of this shell.nix
+  shellConfig = { ... }: {
+    imports = [
+      shell/gnupg.nix
+    ];
+    gnupg = {
+      enable = true;
+      gnupgHome = "../sec/gnupg";
+      gpgExtraConf = ''
+        # julm@sourcephile.fr
+        trusted-key 0xB2450D97085B7B8C
+        default-key 0x4FE467034C11017B429BAC53A58CD81C3863926F
+      '';
+      gpgAgentExtraConf = ''
+        #pretend-request-origin remote
+        #extra-socket ${toString ./.}/S.gpg-agent.extra
+        #log-file ${toString ./.}/gpg-agent.log
+        #no-grab
+        #debug-level expert
+        #allow-loopback-pinentry
+      '';
+    };
+    /*
+      openssl = {
+      enable = true;
+      opensslHome = "../sec/openssl";
+      certificates = import shell/x509.nix;
+      };
+    */
+    openssh = {
+      enable = true;
+      sshConf = ''
+        Ciphers aes256-gcm@openssh.com,aes128-gcm@openssh.com,aes256-ctr
+        Compression no
+        #CompressionLevel 4
+        ControlMaster auto
+        ControlPath .ssh-%h-%p-%r.socket
+        HashKnownHosts no
+        #SSAPIAuthentication no
+        SendEnv LANG LC_*
+        StrictHostKeyChecking yes
+        #UserKnownHostsFile ''${inputs.secrets + "/ssh/known_hosts"}
+      '';
     };
-  */
-  commonsoft-nix-build =
-    pkgs.buildEnv {
-      name        = "commonsoft-nix-build";
-      pathsToLink = [ "/bin" ];
-      paths       = with commonsoft-nix-build-modules; [
-        gnupg.init
-        #gnupg.gpg-fingerprint
-        #nix-plugins.nix-with-extra-builtins
-      ];
+    virtualbox = {
+      enable = false;
     };
+  };
+
+  # Using modules enables to separate specific configurations
+  # from reusable code in shell/modules.nix and shell/modules/
+  # which may find its way in another git repository one day.
+  shell = (pkgs.lib.evalModules {
+    modules = [
+      shellConfig
+      { config._module.args = { inherit inputs pkgs; }; }
+    ] ++ map import (pkgs.lib.findFiles ".*\\.nix" shell/modules);
+  }).config;
 in
-pkgs.stdenv.mkDerivation {
-  name = "commonsoft-nix";
+pkgs.mkShell {
+  name = "sourcephile-nix";
   src = null;
   #preferLocalBuild = true;
   #allowSubstitutes = false;
-  buildInputs = [
-    commonsoft-nix-build
-    nixpkgs
+  buildInputs = shell.nix-shell.buildInputs ++ [
+    (pkgs.nixos [ ]).nixos-generate-config
+    (pkgs.nixos [ ]).nixos-install
+    pkgs.nixos-enter
     #pkgs.binutils
     pkgs.coreutils
     pkgs.cryptsetup
     pkgs.curl
-    pkgs.direnv
-    #pkgs.dnsutils
+    #pkgs.direnv
+    pkgs.dnsutils
+    #pkgs.dropbear
+    pkgs.e2fsprogs
     pkgs.git
-    (pkgs.glibcLocales.override {
-        allLocales = false;
-        locales = [
-          "en_US.UTF-8/UTF-8"
-          "fr_FR.UTF-8/UTF-8"
-        ];
-      })
+    pkgs.glibcLocales
     pkgs.gnumake
     pkgs.gnupg
     pkgs.htop
     #pkgs.inetutils
+    pkgs.ipcalc
+    #pkgs.iputils
     pkgs.less
     pkgs.libfaketime
+    pkgs.ldns
+    #pkgs.ldns.examples
     #pkgs.mailutils
     pkgs.man
+    pkgs.mdadm
+    pkgs.gptfdisk
     pkgs.ncdu
     pkgs.ncurses
-    pkgs.nixops
+    #pkgs.nixops
     #pkgs.openssl
     pkgs.pass
     pkgs.procps
+    pkgs.rsync
     #pkgs.rxvt_unicode.terminfo
     #pkgs.sqlite
     pkgs.sqlite
-    pkgs.sudo
+    #pkgs.sudo
     pkgs.tig
     pkgs.time
     #pkgs.tmux
     pkgs.tree
     pkgs.utillinux
-    pkgs.vim
+    #pkgs.vim
     #pkgs.virtualbox
     pkgs.which
-    pkgs.xdg_utils
+    pkgs.xdg-utils
+    pkgs.fio
+    pkgs.strace
+    pkgs.utillinux
+    #pkgs.zfstools
+    pkgs.linuxPackages.perf
+    #pkgs.go2nix
+    pkgs.wireguard-tools
+    pkgs.stun
+    pkgs.mkpasswd
+    #pkgs.ubootTools
+    #pkgs.hydra-unstable
   ];
   #enableParallelBuilding = true;
-  shellHook = ''
-    # nix
-    export NIX_PATH="nixpkgs=${nixpkgs}:nixpkgs-commonsoft=$PWD/lib/nixpkgs-commonsoft"
-    #NIX_PATH+=":nixpkgs-overlays="$PWD"/install/overlays.nix"
-    #NIX_PATH+=""
 
-    # executables
-    PATH_NIX=$(dirname $(readlink ~/.nix-profile/bin/nix))
-    PATH_NIXOS=/run/wrappers/bin
-    PATH_FHS="$PWD"/.lib/nix/fhs-bin
-    PATH_FHS_VBOX="$PWD"/.lib/fhs-vbox-bin
-    export PATH="$PATH_NIXOS:$PATH_FHS_VBOX:$PATH_FHS:$PATH:$PATH_NIX"
-    ln -sfn ${commonsoft-nix-build}/bin "$PWD"/.bin
+  NIX_PATH = pkgs.lib.concatStringsSep ":" [
+    "nixpkgs=${pkgs.path}"
+    ("nixpkgs-overlays=" + pkgs.writeText "overlays.nix" ''
+      import ${inputs.self + "/nixpkgs/overlays.nix"} ++
+      import ${inputs.julm-nix + "/nixpkgs/overlays.nix"}
+    '')
+  ];
 
-    # NOTE: sudo needs to be own by root with the setuid bit,
-    # but this won't be the case for the sudo provided by Nix outside NixOS,
-    # hence the addition of $PATH_FHS in shellHook
-    # to provide the host system's sudo.
-    # WARNING: beware that sudo may reset the environment,
-    # and especially PATH, to some system's default.
+  shellHook = ''
+    echo >&2 "nix: running shellHook"
 
-    # locales
-    export LANG=fr_FR.UTF-8
-    export LC_CTYPE=fr_FR.UTF-8
+    ${shell.nix-shell.shellHook}
 
     # gpg
-    gpgconf --launch gpg-agent
-    export SSH_AUTH_SOCK=$(gpgconf --list-dirs agent-ssh-socket)
+    export GNUPGHOME=$(realpath -e ${shell.gnupg.gnupgHome});
     export GPG_TTY=$(tty)
-    export GNUPGHOME="$PWD"/../sec/gnupg
-    install -dm700 "$GNUPGHOME"
-
-    # password-store
-    export PASSWORD_STORE_DIR="$PWD"/../sec/pass
-
-    # git
-    ln -fnsr \
-     "$PWD"/.lib/git/hooks/prepare-commit-msg--longuest-common-prefix \
-     "$PWD"/.git/hooks/prepare-commit-msg
-
-    # nixops
-    export NIXOPS_DEPLOYMENT="virtualbox"
-    export NIXOPS_STATE="$PWD"/.var/nixops/state.nixops
-    # Extend the Nix interpreter
-    # to enable builtins.extraBuiltins,
-    # which provides an unsafe exec useful to get secrets
-    # from the local password-store.
-    NIXOPS_OPTS+=" --show-trace"
-    NIXOPS_OPTS+=" --option plugin-files ${pkgs.nix-plugins}/lib/nix/plugins/libnix-extra-builtins.so"
-    NIXOPS_OPTS+=" --option extra-builtins-file ${commonsoft-nix-build-modules.nix-plugins.extra-builtins}"
-    export NIXOPS_OPTS
+    gpg-connect-agent updatestartuptty /bye >/dev/null
 
-    # disnix
-    #export DISNIXOS_USE_NIXOPS=1
-    #export DISNIX_CLIENT_INTERFACE=disnix-nixops-client
-    #export DISNIX_PROFILE=default
-    #export DISNIX_TARGET_PROPERTY=hostname
-    #export DYSNOMIA_STATEDIR=var/dysnomia
-  '';
+    # pass
+    export PASSWORD_STORE_DIR="$PWD"
+  '' + shellHook;
 }