nix: update input secrets
[sourcephile-nix.git] / nixos / profiles / hardware / dl10j.nix
index 38ce9386fa8265b0b64d9732cf12f21aae67b850..73dd09c72df4136e95803ecdc314534acee8c6d6 100644 (file)
@@ -1,4 +1,4 @@
-{ pkgs, lib, config, host, ... }:
+{ pkgs, lib, config, ... }:
 {
 hardware.cpu.intel.updateMicrocode = true;
 hardware.opengl = {
@@ -9,11 +9,10 @@ hardware.opengl = {
     pkgs.libvdpau-va-gl
   ];
 };
-nix = {
-  # Too CPU hungry for the DL10J, for too little Mio saved
-  autoOptimiseStore = false;
-  maxJobs = host.CPUs;
-};
+
+# Too CPU hungry for this hardware, for too little Mio saved
+nix.settings.auto-optimise-store = false;
+
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
 # https://insanity.industries/post/sata-power-consumption/
@@ -22,6 +21,10 @@ services.udev.extraRules = ''
 '';
 
 boot.loader = {
+  efi = {
+    canTouchEfiVariables = false;
+    efiSysMountPoint = "/boot/efi";
+  };
   grub = {
     enable = true;
     version = 2;
@@ -41,10 +44,6 @@ boot.loader = {
     ];
     */
   };
-  efi = {
-    canTouchEfiVariables = false;
-    efiSysMountPoint = "/boot/efi";
-  };
 };
 
 boot.initrd = {
@@ -71,9 +70,13 @@ boot.initrd = {
     "igb" # Ethernet
     "nvme" # NVME M.2 disk
     "rtsx_usb_sdmmc" # SD card
+    "ums_realtek" # SD card
   ];
 };
-boot.kernelModules = [ ];
+boot.kernelModules = [
+  "rtsx_usb_sdmmc" # SD card
+  "ums_realtek" # SD card
+];
 boot.extraModulePackages = [ ];
 boot.kernelParams = [
   "gfxpayload=text"