-{ pkgs, lib, config, host, ... }:
+{ pkgs, lib, config, ... }:
{
hardware.cpu.intel.updateMicrocode = true;
hardware.opengl = {
pkgs.libvdpau-va-gl
];
};
-nix = {
- # Too CPU hungry for the DL10J, for too little Mio saved
- autoOptimiseStore = false;
- maxJobs = host.CPUs;
-};
+
+# Too CPU hungry for this hardware, for too little Mio saved
+nix.settings.auto-optimise-store = false;
+
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
# https://insanity.industries/post/sata-power-consumption/
'';
boot.loader = {
+ efi = {
+ canTouchEfiVariables = false;
+ efiSysMountPoint = "/boot/efi";
+ };
grub = {
enable = true;
version = 2;
];
*/
};
- efi = {
- canTouchEfiVariables = false;
- efiSysMountPoint = "/boot/efi";
- };
};
boot.initrd = {
"igb" # Ethernet
"nvme" # NVME M.2 disk
"rtsx_usb_sdmmc" # SD card
+ "ums_realtek" # SD card
];
};
-boot.kernelModules = [ ];
+boot.kernelModules = [
+ "rtsx_usb_sdmmc" # SD card
+ "ums_realtek" # SD card
+];
boot.extraModulePackages = [ ];
boot.kernelParams = [
"gfxpayload=text"