prosody: increase http_file_share limits
[sourcephile-nix.git] / nixos / profiles / hardware / dl10j.nix
index 4310da01434620c37025f500c07e21ffb674a72d..965a5dc9f5ac901793bd4b7c3f23ea6af250969d 100644 (file)
@@ -1,5 +1,10 @@
-{ pkgs, lib, config, host, ... }:
+{ pkgs, lib, config, ... }:
 {
+nixpkgs.hostPlatform = {
+  system = "x86_64-linux";
+  config = "x86_64-unknown-linux-gnu";
+};
+_module.args.CPUs = 2;
 hardware.cpu.intel.updateMicrocode = true;
 hardware.opengl = {
   extraPackages = [
@@ -9,11 +14,10 @@ hardware.opengl = {
     pkgs.libvdpau-va-gl
   ];
 };
-nix = {
-  # Too CPU hungry for the DL10J, for too little Mio saved
-  autoOptimiseStore = false;
-  maxJobs = host.CPUs;
-};
+
+# Too CPU hungry for this hardware, for too little Mio saved
+nix.settings.auto-optimise-store = false;
+
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
 # https://insanity.industries/post/sata-power-consumption/
@@ -21,11 +25,11 @@ services.udev.extraRules = ''
   SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
 '';
 
-boot.loaded.efi = {
-  canTouchEfiVariables = false;
-  efiSysMountPoint = "/boot/efi";
-};
 boot.loader = {
+  efi = {
+    canTouchEfiVariables = false;
+    efiSysMountPoint = "/boot/efi";
+  };
   grub = {
     enable = true;
     version = 2;