-{ pkgs, lib, config, host, ... }:
+{ pkgs, lib, config, ... }:
{
+nixpkgs.hostPlatform = {
+ system = "x86_64-linux";
+ config = "x86_64-unknown-linux-gnu";
+};
+_module.args.CPUs = 2;
hardware.cpu.intel.updateMicrocode = true;
hardware.opengl = {
extraPackages = [
pkgs.libvdpau-va-gl
];
};
-nix = {
- # Too CPU hungry for the DL10J, for too little Mio saved
- autoOptimiseStore = false;
- maxJobs = host.CPUs;
-};
+
+# Too CPU hungry for this hardware, for too little Mio saved
+nix.settings.auto-optimise-store = false;
+
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
# https://insanity.industries/post/sata-power-consumption/
SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
'';
-boot.loaded.efi = {
- canTouchEfiVariables = false;
- efiSysMountPoint = "/boot/efi";
-};
boot.loader = {
+ efi = {
+ canTouchEfiVariables = false;
+ efiSysMountPoint = "/boot/efi";
+ };
grub = {
enable = true;
version = 2;