sourcehut: update patch
[sourcephile-nix.git] / hosts / losurdo / hardware.nix
index 69fae97d03e963d308d628b99ed4138112c11161..bc630ae2bb37cc2d600f73c1a80a83aafa2434d1 100644 (file)
@@ -5,20 +5,13 @@ imports = [
   ../../nixos/profiles/systems/zramSwap.nix
 ];
 
+hardware.opengl.enable = true;
+
 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
 # You should try to make this id unique among your hosts.
 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
 networking.hostId = "e18f71a6";
 
-hardware.opengl = {
-  extraPackages = [
-    pkgs.intel-media-driver # LIBVA_DRIVER_NAME=iHD
-    pkgs.vaapiIntel         # LIBVA_DRIVER_NAME=i965 (older but works better for Firefox/Chromium)
-    pkgs.vaapiVdpau
-    pkgs.libvdpau-va-gl
-  ];
-};
-
 boot.loader.grub.devices = [
   #"/dev/disk/by-id/nvme-Samsung_SSD_970_EVO_Plus_250GB_S4EUNJ0N211426T"
   #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
@@ -52,4 +45,7 @@ swapDevices = [
     };
   }
 ];
+
+# Allow access to Yubikey USB device nodes.
+services.udev.packages = [ pkgs.yubikey-personalization ];
 }