let
# Configuration of shell/modules/
# to expand shellHook and buildInputs of this shell.nix
- shellConfig = {config, ...}: {
+ shellConfig = { ... }: {
imports = [
shell/gnupg.nix
];
'';
};
/*
- openssl = {
+ openssl = {
enable = true;
opensslHome = "../sec/openssl";
certificates = import shell/x509.nix;
- };
+ };
*/
openssh = {
enable = true;
#preferLocalBuild = true;
#allowSubstitutes = false;
buildInputs = shell.nix-shell.buildInputs ++ [
- (pkgs.nixos []).nixos-generate-config
- (pkgs.nixos []).nixos-install
- (pkgs.nixos []).nixos-enter
+ (pkgs.nixos [ ]).nixos-generate-config
+ (pkgs.nixos [ ]).nixos-install
+ (pkgs.nixos [ ]).nixos-enter
#pkgs.binutils
pkgs.coreutils
pkgs.cryptsetup
#pkgs.vim
#pkgs.virtualbox
pkgs.which
- pkgs.xdg_utils
+ pkgs.xdg-utils
pkgs.fio
pkgs.strace
pkgs.utillinux
];
#enableParallelBuilding = true;
- GNUPGHOME = shell.gnupg.gnupgHome;
NIX_PATH = pkgs.lib.concatStringsSep ":" [
"nixpkgs=${pkgs.path}"
("nixpkgs-overlays=" + pkgs.writeText "overlays.nix" ''
${shell.nix-shell.shellHook}
# gpg
+ export GNUPGHOME=$(realpath -e ${shell.gnupg.gnupgHome});
export GPG_TTY=$(tty)
gpg-connect-agent updatestartuptty /bye >/dev/null