nix: update input julm-nix
[sourcephile-nix.git] / shell.nix
index 47061c4cf30a8334ddee72a37b0350e0410339cf..477117f8924f1610b7f5e6e952e09fecfe4d71af 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -2,7 +2,7 @@
 let
   # Configuration of shell/modules/
   # to expand shellHook and buildInputs of this shell.nix
-  shellConfig = {config, ...}: {
+  shellConfig = { ... }: {
     imports = [
       shell/gnupg.nix
     ];
@@ -24,11 +24,11 @@ let
       '';
     };
     /*
-    openssl = {
+      openssl = {
       enable = true;
       opensslHome = "../sec/openssl";
       certificates = import shell/x509.nix;
-    };
+      };
     */
     openssh = {
       enable = true;
@@ -66,9 +66,9 @@ pkgs.mkShell {
   #preferLocalBuild = true;
   #allowSubstitutes = false;
   buildInputs = shell.nix-shell.buildInputs ++ [
-    (pkgs.nixos []).nixos-generate-config
-    (pkgs.nixos []).nixos-install
-    (pkgs.nixos []).nixos-enter
+    (pkgs.nixos [ ]).nixos-generate-config
+    (pkgs.nixos [ ]).nixos-install
+    (pkgs.nixos [ ]).nixos-enter
     #pkgs.binutils
     pkgs.coreutils
     pkgs.cryptsetup
@@ -112,7 +112,7 @@ pkgs.mkShell {
     #pkgs.vim
     #pkgs.virtualbox
     pkgs.which
-    pkgs.xdg_utils
+    pkgs.xdg-utils
     pkgs.fio
     pkgs.strace
     pkgs.utillinux
@@ -127,7 +127,6 @@ pkgs.mkShell {
   ];
   #enableParallelBuilding = true;
 
-  GNUPGHOME = shell.gnupg.gnupgHome;
   NIX_PATH = pkgs.lib.concatStringsSep ":" [
     "nixpkgs=${pkgs.path}"
     ("nixpkgs-overlays=" + pkgs.writeText "overlays.nix" ''
@@ -142,6 +141,7 @@ pkgs.mkShell {
     ${shell.nix-shell.shellHook}
 
     # gpg
+    export GNUPGHOME=$(realpath -e ${shell.gnupg.gnupgHome});
     export GPG_TTY=$(tty)
     gpg-connect-agent updatestartuptty /bye >/dev/null