nix: update to latest nixpkgs
[sourcephile-nix.git] / nixos / profiles / hardware / dl10j.nix
index bb36a00737059cfa6527fb2be34b209df415a8ef..b488e437a487b06ba7750548a389e8b9738f5c99 100644 (file)
@@ -1,10 +1,10 @@
-{ pkgs, lib, config, ... }:
+{ pkgs, lib, config, host, ... }:
 {
 hardware.cpu.intel.updateMicrocode = true;
 nix = {
   # Too CPU hungry for the DL10J, for too little Mio saved
   autoOptimiseStore = false;
-  maxJobs = 2;
+  maxJobs = host.CPUs;
 };
 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
 
@@ -18,7 +18,7 @@ boot.loader = {
     enable = true;
     version = 2;
     copyKernels = true;
-    configurationLimit = 3;
+    configurationLimit = 9;
     efiSupport = true;
     # Because canTouchEfiVariables doesn't work on this system
     efiInstallAsRemovable = true;
@@ -53,9 +53,9 @@ boot.initrd = {
     "xhci_hcd" # USB
     #"i915" # VGA
     "igb" # Ethernet
-    # Made the AES modules available at initrd,
+    # Make the AES modules available at initrd,
     # to speedup the deciphering of the root.
-    "aes_x86_64"
+    #"aes_x86_64"
     "aesni_intel"
     "cryptd"
   ];