-{ pkgs, lib, config, ... }:
+{ pkgs, lib, config, host, ... }:
{
hardware.cpu.intel.updateMicrocode = true;
nix = {
# Too CPU hungry for the DL10J, for too little Mio saved
autoOptimiseStore = false;
- maxJobs = 2;
+ maxJobs = host.CPUs;
};
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
enable = true;
version = 2;
copyKernels = true;
- configurationLimit = 3;
+ configurationLimit = 9;
efiSupport = true;
# Because canTouchEfiVariables doesn't work on this system
efiInstallAsRemovable = true;
"xhci_hcd" # USB
#"i915" # VGA
"igb" # Ethernet
- # Made the AES modules available at initrd,
+ # Make the AES modules available at initrd,
# to speedup the deciphering of the root.
- "aes_x86_64"
+ #"aes_x86_64"
"aesni_intel"
"cryptd"
];