{ pkgs, lib, config, ... }:
-let cfg = config.openssh;
- inherit (lib) types;
+let
+ cfg = config.openssh;
+ inherit (lib) types;
in
{
options.openssh = {
};
config = lib.mkIf cfg.enable {
nix-shell.buildInputs =
- let ssh = pkgs.writeShellScriptBin "ssh" ''
+ let
+ ssh = pkgs.writeShellScriptBin "ssh" ''
${pkgs.openssh}/bin/ssh -F ${cfg.sshConf} "$@"
'';
in